[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Savannah-hackers-public] bzr access problems

From: Eli Zaretskii
Subject: Re: [Savannah-hackers-public] bzr access problems
Date: Wed, 12 Oct 2011 13:27:19 +0200

> Date: Mon, 10 Oct 2011 16:00:33 +1100
> From: Tim Cross <address@hidden>
> Starting this morning, I am unable to do a pull from the bzr repo for
> emacs. I also tried to do a fresh bzr branch with the same result.
> The commands I've tried using and the errors I am seeing follow
> address@hidden:~/bzr/emacs/trunk$ bzr pull
> Using saved parent location:
> bzr: ERROR: Cannot lock
> LockDir(filtered-172943884:///emacs/trunk/.bzr/branch/lock):
> Permission denied:
> "/srv/bzr/emacs/trunk/.bzr/branch/lock/0m3a6hs09w.tmp": [Errno 13]
> Permission denied:
> '/srv/bzr/emacs/trunk/.bzr/branch/lock/0m3a6hs09w.tmp'
> For a fresh branch (or for a bzr pull on an existing branch) I get the
> same error i.e.
> address@hidden:~/tmp/bzr$ bzr branch bzr://
> bzr: ERROR: Connection closed: Unexpected end of message. Please check
> connectivity and permissions, and report a bug if problems persist.
> address@hidden:~/tmp/bzr$
> I don't think there are any network connectivity issues as I can
> ping/traceroute fine. The error from the http method would indicate
> I'm accessing the server, but that some file has bad permissions.

Perhaps as continuation of this problem, there's now an intermittent
problem with accessing Emacs's bzr repo.  I reproduce below the
fragment from my .bzr.log, for one time I caught it with -Dhpss.

Could someone please look into this?  TIA.

  Wed 2011-10-12 13:17:32 +0200
  0.141  bazaar version: 2.4.1
  0.141  bzr arguments: [u'-Dhpss', u'up']
  0.203  looking for plugins in C:/Documents and Settings/Zaretzky/Application 
  0.203  looking for plugins in D:/usr/Bazaar/plugins
  0.328  encoding stdout as sys.stdout encoding 'cp1252'
  0.375  opening working tree 'D:/gnu/bzr/emacs/trunk'
  0.422  hpss: Built a new medium: SmartSSHClientMedium
  0.422  hpss call:   'BzrDir.open_2.1', 'emacs/trunk/'
  0.422               (to bzr+ssh://address@hidden/emacs/trunk/)
  0.641  ssh implementation is Putty's plink.
  21.578  decoder state: buf[:10]='', 
  21.578  Transferred: 0kB (0.0kB/s r:0kB w:0kB)
  21.594  Traceback (most recent call last):
    File "bzrlib\commands.pyo", line 946, in exception_to_return_code
    File "bzrlib\commands.pyo", line 1150, in run_bzr
    File "bzrlib\commands.pyo", line 699, in run_argv_aliases
    File "bzrlib\commands.pyo", line 721, in run
    File "bzrlib\cleanup.pyo", line 135, in run_simple
    File "bzrlib\cleanup.pyo", line 165, in _do_with_cleanups
    File "bzrlib\builtins.pyo", line 1474, in run
    File "bzrlib\decorators.pyo", line 154, in read_locked
    File "bzrlib\branch.pyo", line 2597, in get_master_branch
    File "bzrlib\branch.pyo", line 2606, in _get_master_branch
    File "bzrlib\branch.pyo", line 184, in open
    File "bzrlib\bzrdir.pyo", line 828, in open
    File "bzrlib\bzrdir.pyo", line 863, in open_from_transport
    File "bzrlib\bzrdir.pyo", line 1590, in open
    File "bzrlib\remote.pyo", line 293, in _open
    File "bzrlib\remote.pyo", line 356, in __init__
    File "bzrlib\remote.pyo", line 368, in _probe_bzrdir
    File "bzrlib\remote.pyo", line 375, in _rpc_open_2_1
    File "bzrlib\remote.pyo", line 56, in _call
    File "bzrlib\smart\client.pyo", line 132, in call
    File "bzrlib\smart\client.pyo", line 145, in call_expecting_body
    File "bzrlib\smart\client.pyo", line 93, in _call_and_read_response
    File "bzrlib\smart\message.pyo", line 299, in read_response_tuple
    File "bzrlib\smart\message.pyo", line 264, in _wait_for_response_args
    File "bzrlib\smart\message.pyo", line 286, in _read_more
  ConnectionReset: Connection closed: Unexpected end of message. Please check 
connectivity and permissions, and report a bug if problems persist. 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]