[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Savannah-hackers-public] bzr access problems

From: Martin Pool
Subject: Re: [Savannah-hackers-public] bzr access problems
Date: Thu, 13 Oct 2011 10:17:06 +1100

On 10 October 2011 16:00, Tim Cross <address@hidden> wrote:
> Starting this morning, I am unable to do a pull from the bzr repo for
> emacs. I also tried to do a fresh bzr branch with the same result.
> The commands I've tried using and the errors I am seeing follow
> address@hidden:~/bzr/emacs/trunk$ bzr pull
> Using saved parent location:
> bzr: ERROR: Cannot lock
> LockDir(filtered-172943884:///emacs/trunk/.bzr/branch/lock):
> Permission denied:
> "/srv/bzr/emacs/trunk/.bzr/branch/lock/0m3a6hs09w.tmp": [Errno 13]
> Permission denied:
> '/srv/bzr/emacs/trunk/.bzr/branch/lock/0m3a6hs09w.tmp'

Hi Tim,

This is bzr seeing an errno 13 from the OS when it tries to take that
lock.  It is strange that it's trying to lock when you are doing a
readonly operation. I would like to see the traceback which should be
in the server log, and perhaps an admin could do a 'ls -lR' and check
the permissions are as they should be.

I'm apparently successfully pulling from there at the moment.

> For a fresh branch (or for a bzr pull on an existing branch) I get the
> same error i.e.
> address@hidden:~/tmp/bzr$ bzr branch bzr://
> bzr: ERROR: Connection closed: Unexpected end of message. Please check
> connectivity and permissions, and report a bug if problems persist.
> address@hidden:~/tmp/bzr$

This is also just the OS reporting the connection was reset, similar
to what Eli has.  I think either the process is being killed on the
server or there is some kind of connection glitch.  I suppose it's
possible it's a bug in bzr but I can't think what would cause it to
break just then, and I haven't heard of it elsewhere.  Getting a trace
of bzr running on the server could be good.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]