[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Savannah-help-public] Problem with ssh access to git

From: Trevor Daniels
Subject: Re: [Savannah-help-public] Problem with ssh access to git
Date: Thu, 25 Feb 2010 09:00:46 -0000

Sylvain Beucler wrote Thursday, February 25, 2010 7:03 AM

This works for me.

Yes, it seems to work for everyone else, but not for

I issued a 'git gc' just in case.

Tried that.  No change.

I've checked that the call set-up packet is getting
to and through my router, and I've tried using nc.
Still no luck.  I've now exhausted everything in the
SshAccess page and I've run out of ideas.  What else
can I try to diagnose this problem (described below)?


On Thu, Feb 25, 2010 at 12:44:44AM -0000, Trevor Daniels wrote:

I have been able to use ssh to pull and push to lilypond.git at for many months, but sometime between 8 Feb 2010 and 16 Feb 2010 this stopped working with the attempt timing out. I've tried to resolve this by moving to, but I still cannot
push or pull with ssh.  Here's what happens:

$ ssh -v sv
>debug1: Next authentication method: publickey
>debug1: Offering public key: /home/trevor/.ssh/id_dsa
>debug1: Server accepts key: pkalg ssh-dss blen 433
>debug1: Authentication succeeded (publickey).
so my key must be acceptable to savannah.

$ git pull git:// master
pulls correctly, so access to lilypond.git looks fine.

$ git pull ssh://sv/srv/git/lilypond.git master
hangs, and
$ git pull ssh://sv/lilypond.git master
>fatal: '/lilypond.git' does not appear to be a git repository
>fatal: The remote end hung up unexpectedly

My ssh config file contains

IdentityFile ~/.ssh/id_dsa
Host sv
User trevord

Can anyone suggest what I'm doing wrong?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]