[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

GNU screen VIM / terminal garbling on OS X and Cygwin?

From: Seth House
Subject: GNU screen VIM / terminal garbling on OS X and Cygwin?
Date: Wed, 9 Mar 2005 17:03:58 -0700


I've tried to find this information by searching the list archives and
Google, and have spent some time trying to figure this out for myself
to no avail. Part of my problem may be that I'm not entirely sure what
to search for. I would greatly appreciate any advice you all could
offer since this has crippled my ability to use screen on my non-Linux
boxen, and ^a has become second nature to me!

When using screen it will frequently garble the terminal display and
redrawing the display has no effect. This has been most reproducible
when running Vim and scrolling through the buffer.

Since I've had trouble describing this to search engines, I recorded a
little Flash movie of the problem to better describe it to this list.
It's a little messy looking, but keep an eye out for the statusline in
Vim moving up a line, effectively hiding the first line of the file,
and the line numbers repeating themselves just below the statusline.
Also upon exit the display won't echo the output of any programs until
I run clear.

Initially I thought it might be related to my hardstatus entry but the
problem also happens with the hardstatus example directly from the
screen manpage. However, it does *not* happen if I run screen without
a hardstatus. Nor does it happen when I run Vim without screen.

Here is my ~/.screenrc

I'm running GNU screen on Mac OS X (Panther) which I installed from
Fink (version 4.00.02 (FAU) 5-Dec-03), however I have the same problem
with the version that ships with Panther (3.09.15 (FAU) 13-Mar-03).
The problem appears both in and xterm under X11. I have
tried pasting the full text of the /etc/screenrc file that comes with
Fink into my .screenrc since it has terminfo settings with no effect.
Lastly, the problem has also shown up in Cygwin (version 4.00.02 (FAU)
5-Dec-03) (don't remember where I got the binary).

Sorry for the long post, and thanks for reading if you got this far, I
would really, greatly appreciate any advice!

- whiteinge

reply via email to

[Prev in Thread] Current Thread [Next in Thread]