[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Window resizing and F10 not working

From: Trebor Sreyb
Subject: Window resizing and F10 not working
Date: Thu, 11 Aug 2005 11:10:25 -0700 (PDT)

OK, my head is spinning like a top. There are two
problems I'm having with screen:

1. Cannot resize the window ("Your termcap does not
specify how to change the terminal's width to 132")

2. Function key F10 is not properly mapped.

I tried to tackle #1 first. I added this to the
'screen' definition in /etc/termcap:


I also added these to /usr/local/etc/screenrc:
termcap screen 'WS=\E[8;%d;%dt'
terminfo screen 'WS=\E[8;%d;%dt'

I'm not sure how to update the terminfo file
(/usr/share/lib/terminfo/s/screen), since it is a
binary file. (I tried using 'tic' to compile my
/etc/termcap, but it always generates a coredump)

I'm using screen 4.00.02 on Solaris 5.9. I've
confirmed my TERM is set to 'screen', though the same
problem occurs if I force TERM to 'xterm'. My actual
session is via an xterm (problem is same for a TELNET
session and an rlogin session opened from cygwin and
from putty)

% env | head -24
TERMCAP=SC|screen|VT 100/ANSI X3.64 virtual terminal:\


Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]