[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Weird problem using 'hardcopy' -> Blank screen when never opened in real

From: Gekke Prutser
Subject: Weird problem using 'hardcopy' -> Blank screen when never opened in real terminal
Date: Mon, 11 Jun 2007 11:34:42 +0100

Hi Everyone!

I was hoping you might know about this problem I've been having with 'screen' in the last while. I've done a lot to try and solve it, and looked all over the internet and this mailing list, but I can't seem to find the solution.

I'm starting several screen sessions on startup of a server using named screens ("screen -S"). These sessions each run a game server.

I can connect to the screen using a running terminal session with "screen -x" as usual. I also made a front-end where admins can quickly check the status of a running screen session, which uses the 'hardcopy' function to make a screen shot, which is then displayed on the web page. This works well if I ever used "screen -x" before to connect to that particular screen session.

However, if I have never used screen -x manually since bootup, the screendump is always empty (0 bytes). I assumed this was because it doesn't know the terminal type or something but I have tried specifying this manually in the shell .bashrc and I have tried sending a 'redisplay' and 'height 24 80' command to screen before doing the hardcopy. I have even tried to associate a process running 'screen -x' with one of the virtual terminals on the console at startup. But none of this worked, the only way to get a functioning screendump using hardcopy seems to be to run a session of 'screen -x' and then quit it. After that it works brilliantly till the next reboot.

I was just wondering if someone else has the same problem and more importantly if you know how to fix it :) It would be great to have this working so I don't have to give each admin SSH access to our game server.


Tycho Schenkeveld (GekkePrutser)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]