[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Terminal resize problem

From: Ciprian Dorin, Craciun
Subject: Re: Terminal resize problem
Date: Fri, 12 Feb 2010 23:25:30 +0200

On Fri, Feb 12, 2010 at 10:55 PM, Sadrul Habib Chowdhury
<address@hidden> wrote:
> * Ciprian Dorin, Craciun had this to say on [11 Feb 2010, 09:23:42 +0200]:
>> On Mon, Feb 8, 2010 at 7:17 AM, J. Bakshi <address@hidden> wrote:
>> > On 02/08/2010 10:44 AM, J. Bakshi wrote:
>> >> Dear list,
>> >>
>> >> I have found many discussion in net on the terminal resize issue and I
>> >> have tried the solutions as given but no success yet. I am using mrxvt
>> >> in my workstation. after logging into the remote box I started screen.
>> >> Also set "TERM=xterm" . And now the real problem. If I resize the
>> >> terminal; screen still stick with that size when it was called. [ctrl+a
>> >> :fit] did not solve the problem. I have also supplied "eval resize" in
>> >> .screenrc but no luck. Is there any way to practically fix it ?
>> >>
>> >> thanks
>> >>
>> >>
>> >
>> > BTW: The problem is not there if I don't use hardstatus  and I need
>> > hardstatus as I generally open a no. of session
>>     Hy there.
>>     I have a similar problem with my setup. (I use an
>> "auto-maximizing" window manager (i3, and before that ion3), and when
>> I open a terminal (rxvt-unicode), with screen in it,
> How do you start rxvt-unicode? How do you create/attach to a session in
> rxvt-unicode?

    The way I start screen:
~~~~ x-shell (my own custom script)

set -e -u -o pipefail || exit 1
test "${#}" -eq 0

export SHELL='/bin/bash'

export XCONSOLE_TITLE='shell'
exec x-console screen -RR

exit 1

    What is behind x-console:
~~~~ x-console

set -e -u -o pipefail || exit 1
test "${#}" -ge 1

test -z "${XCONSOLE_TITLE:-}" || title="${XCONSOLE_TITLE}"

exec urxvt -title "${title}" -e "address@hidden"
exit 1

    So actually it boils down to:
urxvt -title shell -e screen -RR

>> screen thinks
>> that the size of the terminal is smaller (80x25?), but after I press
>> any key and the program redraws something the correct size is found.
>> (This happens only about 33% of the times.)) (I use the latest (or at
>> least quite new version) of screen (from ArchLinux).)
>>     I've tried to solve this problem myself with commands like resize,
>> fit, height, width, etc. No success. The only solution (which I don't
>> find satisfying, but annoying) is to put a 'sleep 1' in my screen.rc,
>> and I've solved the problem. (But every time I open a console I have
>> to stare 1 second at it...)
>>     Any feedback to our problems? :)
> I haven't been able to reproduce this problem, unfortunately, so no.
> Perhaps you could share your .screenrc with us, in case something in
> there is triggering the issue?

    Contents of my setup files:
~~~~ .screenrc
startup_message off

shelltitle 'sh'
shell -/bin/bash

caption always
caption string '%{= }%{+ w}| %-w%{+ r}%n%f%t%{+ w}%+w |%=| %{+ m}%H%{+
w} | %{+ w}%Y-%m-%d/%c%{+ w} | %{+ w}(%l)'
hardstatus ignore
hardstatus string '%h'
activity 'screen activity:[%n]'
bell_msg 'screen bell:[%n]'
vbell_msg 'screen vbell:[%n]'
vbell on

maxwin 10

autodetach on

#bindkey -d -k kb stuff ^H

sleep 1

> What version of screen are you guys using? If you could try out the
> current development version from git
> ( and see if the problem
> is fixed there, that'd be very great.

    My versions are (on Archlinux):
    * screen: 4.0.3-8
    * rxvt-unicode: 9.07-1

    BTW: I think this is a problem rooting from RXVT, because even
alsa-mixer started as `urxvt -e alsamixer` sometimes miss-behaves.

    (When I have some time available I'll also try the version from
Git. But the current problem is not that pressing to me.)

> Cheers,
> Sadrul


reply via email to

[Prev in Thread] Current Thread [Next in Thread]