[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Screen 4.00.03, frozen, can't reattach

From: Timothy Normand Miller
Subject: Screen 4.00.03, frozen, can't reattach
Date: Sat, 20 Nov 2010 17:32:47 -0500

Sorry if this comes up as a duplicate, but I'm confused as to whether
a post on ""; is the same as a
post to the mailing list.  Anyhow...

When using gnu screen, I'm in the habit of just dropping the
connection (I'll put my laptop to sleep, for example), and
periodically, I have screen just refuse to allow me to reattach. I've
tried to do some research on this.

This guy claims to have submitted a patch to fix it:

While this thread claims that there is no good fix:

I've tried all sorts of things to get it unstuck. Attaching/detaching
a debugger, various command-line options, sending signals, etc.
Nothing works.  My situation seems different from the 2009 thread,
because I'm not stuck in write(). Here's what the debugger tells me:

0x00007f59953073c3 in __select_nocancel () at
82      ../sysdeps/unix/syscall-template.S: No such file or directory.
in ../sysdeps/unix/syscall-template.S
(gdb) where
#0 0x00007f59953073c3 in __select_nocancel () at
#1 0x0000000000441ccc in sched () at sched.c:124
#2 0x00000000004062b0 in main (ac=<value optimized out>, av=<value
optimized out>) at screen.c:1365

I'm assuming I found the right process, anyhow. There are no zombie
clients running, so I can't kill any of those. This is the only
process with 'screen' in the name:
millerti 12529 1 0 Nov03 ? 00:00:02 SCREEN

I haven't tried deleting the socket node, but since this seems to be a
new problem, I thought it safer if I were to ask for advice before
doing something that might make it impossible to find out what

What should I do?


Timothy Normand Miller
Open Graphics Project

reply via email to

[Prev in Thread] Current Thread [Next in Thread]