[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: screen doesn't forward keystrokes

From: Lucas Gerads
Subject: Re: screen doesn't forward keystrokes
Date: Wed, 5 Oct 2011 10:10:45 -0400

On Tue, Oct 4, 2011 at 5:36 PM, Lucas Gerads
<address@hidden> wrote:
> On Fri, Sep 30, 2011 at 1:58 PM, Lucas Gerads
> <address@hidden> wrote:
>> I use GNU screen in Ubuntu Linux to connect over a RS232 serial port
>> to an embedded device (which runs Angstrom Linux) When I reboot my
>> embedded device I can see all the messages properly with screen, but I
>> cannot input anything on the target device.
>> I run the commands
>> $ screen /dev/ttyS1 115200
>> this connects me to the target device. The target is already booted up.
>> Now, if I input on the target via screen
>> $ reboot
>> I can see all the shutdown and booting messages, but I cannot input
>> anything via my keyboard. Eventually I arrive on the login screen of
>> my target device, but of course I cannot login. If I kill the screen
>> and then relaunch it with
>>  $ screen /dev/ttyS1 115200
>> everything is fine again. I have to access the bootloader shell on my
>> target device, so I need to be able to input things during the
>> bootprocess. Any ideas what is going on?
>> Thanks in advance
>> Lucas
> I am still experiencing the same problems. I am trying to explain my
> problems again, maybe that makes my problem a little clearer.
> I am doing embedded development. I used to use minicom but experienced
> problems, that seem to be common. In a lot of places "screen" is
> recommended to use to connect over the serial port to the target
> device.
> Maybe the following steps outline my problem better:
> I connect to my target device with the command "$ screen /dev/ttyS1
> 115200". If I boot it up manually,  I am able to read all the booting
> messages, but seem not to be able to input anything (I want to open
> the bootloader). At the end of the boot process, I can of course also
> not login (I run angstrom linux on my target). This is only possible
> when I issue the command "ctrl-a :quit". It takes awfully long until
> screen finally quits. If I then reconnect with the command "$ screen
> /dev/ttyS1 115200", everything seems to be fine and I can login into
> linux on my target device.
> I do not experience this with hyperterminal under windows or minicom
> on linux, but both have other shortcomings, why I would like to switch
> to screen.
> Any ideas?
> -- Lucas

Okay, I am going to continue my monolog.
I downloaded the newest source code of screen and compiled it. I now
have to versions
One that comes from Ubuntu: Screen version 4.00.03jw4 (FAU)
One that I just compiled: Screen version 4.01.00devel (GNU450e8f3)
They both display the same behavior. Killing the screen with "ctrl-a
k" or "ctrl-a :quit" takes very long. Detaching the screen is quick.
Is it possible that screen is busy with something? How could I find
out why it takes so long to kill a screen?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]