[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: screen-4.6.0 regression: within su: Cannot open your terminal '/dev/

From: Axel Beckert
Subject: Re: screen-4.6.0 regression: within su: Cannot open your terminal '/dev/pts/14' - please check
Date: Thu, 29 Jun 2017 13:52:44 +0200
User-agent: Mutt/1.5.21 (2010-09-15)


On Thu, Jun 29, 2017 at 02:31:39PM +0300, Andrew Savchenko wrote:
> I often use screen within su - username sessions, so that active
> terminal (e.g. xterm) is owned by a user different from one using
> su, e.g.:
> su - test
> screen
> This worked fine before 4.6.0 (up to 4.5.1),

That puzzles me as that never worked for me and for many other users
either, see e.g. all these bug reports in Debian:
(all merged into one report as they are about the same issue)

And there is this GNU Screen bug report on Savannah:

> with 4.6.0 I have:
> $ su - test
> $ screen
> Cannot open your terminal '/dev/pts/14' - please check.

I know that behaviour of screen for ages and even saw people
recommending tmux because it doesn't seem to have this issue.

> /dev/pts/14 is indeed not owned by user test, but this way screen
> have worked fine for as long as I can remember, so this access
> should not be mandatory.
> Any way to return the old behaviour?

I'd rather be interested in how you got that working all these years.

                Kind regards, Axel
/~\  Plain Text Ribbon Campaign                   | Axel Beckert
\ /  Say No to HTML in E-Mail and News            | address@hidden  (Mail)
 X   See | address@hidden (Mail+Jabber)
/ \  I love long mails: | (Web)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]