[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Simulavr-devel] Getting Started with simulavrxx

From: Joel Sherrill
Subject: Re: [Simulavr-devel] Getting Started with simulavrxx
Date: Fri, 20 Feb 2009 15:20:39 -0600
User-agent: Thunderbird (X11/20090105)

Klaus Rudolph wrote:

I am trying to get started with simulavrxx and have
some questions.  I am using the Fedora 10 avr tool RPMs.

1) Is "./configure ; make ; make install" the preferred
way to build?

Actually not.

Oh well.  I got it simulavrxx to build both ways. :)

The pin.cpp patch is needed either way.

The patch is needed if someone is
going to ever make the autoconf work.

src/Makefile still needs the -lz option.
I also cleaned up src/Makefile a little so you
didn't have to change the hard-coded /home
directory in as many places.
I got most of the way through a build with this but nots
perfect since the .in files in the examples directories
do not get all the @...@ symbols replaced.
You are right. The examples must go back to the time before autotools.
If you dig in the history of the mailing list you will find out that
there was autotools placed in but many people could not compile on there
systems. So we decided to move back to Makefile and a simple config.h.
As you can see, it works :-) But the examples are not back-patched yet.
Sorry for this.

No problem.  I could tell this from the mailing list but
didn't know which worked so tried both.

I could stand the back patch.  I hacked a bit to fix the path
to but ended up with this:

address@hidden anacomp]$ tclsh check.tcl
couldn't load file "../../src/": ../../src/ undefined symbol: inflateInit_
   while executing
"load ../../src/"
   (file "check.tcl" line 8)

Patch with ChangeLog attached for a few issues.  With these
I got a simulavrxx executable on Fedora 10.

2) Can someone explain how to get the gui to run?  It is
trying to load and I don't see it built.
Can you read the texi file first. Thanks! :-)
If you have to much trouble with the @..@ symbols feel free to ask for

OK not I have it trying to run but as you can see from above there
are other issues.  Apparently it needs other .so files.
#include <stdio.h>
int main() {
 puts( "hello\n" );
....../simulavr -f hello -d atmega128 -Texit

If so, where does the output go?  I see nothing but the program
appears to run correctly according to the trace file.

There is no output :-)
You have not asked anything to print out.
Huh? I used stdout via puts.  Where did that go?

If I want to print am I supposed to do something
similar to "fred.c"?

I have used avrtest and it has a few "magic addresses"

#define STDIO_PORT      0x52
#define EXIT_PORT       0x4F
#define ABORT_PORT      0x49

Where does the UART go?
I see mention of this in the command line help:

-u run with user interface for external pin handling at port 7777

Does this mean I can see the pins changing when the GUI runs?

 If you wish, try -t option.

....../simulavr -f hello -d atmega128 -Texit -ttrace
....../simulavr -f hello -d atmega128 -Texit -t/dev/stdout
last will print on screen, first in file "trace"

After execution you have the trace data in "trace". Or use other options
for statistics (not sense full without irq) or for debugging with
gdb/ddd or others.

OK but I wanted stdout, not a trace of the execution.
Hope that helps a bit
Yes.  Still trying to get things in my head and some working
examples. :)

For the examples I will take a look next week.

Thanks.  I am sorry to be a pain.  I'm really a good user. :)

Simulavr-devel mailing list

Joel Sherrill, Ph.D.             Director of Research & Development
address@hidden        On-Line Applications Research
Ask me about RTEMS: a free RTOS  Huntsville AL 35805
  Support Available             (256) 722-9985

reply via email to

[Prev in Thread] Current Thread [Next in Thread]