[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Simulavr-devel] [sr #106796] ./configure does not generate working make

From: anonymous
Subject: [Simulavr-devel] [sr #106796] ./configure does not generate working makefiles
Date: Tue, 02 Jun 2009 02:16:10 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/2008102920 Firefox/3.0.4


                 Summary: ./configure does not generate working makefiles
                 Project: Simulavr: an AVR simulator
            Submitted by: None
            Submitted on: Tue 02 Jun 2009 02:16:08 AM UTC
                Category: bugs
                Priority: 5 - Normal
                Severity: 3 - Normal
                  Status: None
                 Privacy: Public
             Assigned to: None
        Originator Email: address@hidden
             Open/Closed: Open
         Discussion Lock: Any
       Component Version: simulavrxx
        Operating System: GNU/Linux




I just tried to build simulavrxx against binutils-2.19.1 and the makefiles
generated by ./configure had two errors. 

The configure line I used was:

./configure --with-bfd-path=../binutils-2.19.1/bfd/

The errors were:
1. in the src/Makefile the variables below looked like:
     bfd_a_location = ../../binutils-2.19.1/bfd//
     bfd_h_location = ../../binutils-2.19.1/bfd//
   when they needed to be:
     bfd_a_location = ../../binutils-2.19.1/bfd//
     bfd_h_location = ../../binutils-2.19.1/bfd//
2. The line:
     LIBS = -lncurses
   needed to be:
     LIBS = -lncurses -lz 
   to stop lots of complaints about missing symbols in compress.c
   from binutils (I guess they now using compression from libz)

Once I fixed these things seemed to be OK.




Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]