[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Tlf-devel] Using TLF with hamlib

From: Bob Nielsen
Subject: [Tlf-devel] Using TLF with hamlib
Date: Mon, 2 May 2005 16:55:09 -0700
User-agent: Mutt/1.5.6+20040907i

I finally got around to trying to interface my TS-570D to my computer.  
It works fine with grig, but I haven't been able to get the rig to talk 
to TLF.

I ran configure with --enable-hamlib.  It appears to recognize hamlib:

checking for main in -lhamlib... yes
checking hamlib/rig.h usability... yes
checking hamlib/rig.h presence... yes
checking for hamlib/rig.h... yes
enabling hamlib support

However, checking the resultant config.h, I see:

/* Define if you have the <hamlib/riglist.h> header file. */

However, /usr/include/hamlib/riglist.h exists.

I compiled TLF and enabled rig control in logcfg.dat, setting RIGMODEL, 
RIGSPEED and RIGPORT to the appropriate values.  When I run TLF, I get 
the following:

Trying to start rig ctrl
rig_open: error

Editing config.h to define HAVE_HAMLIB_RIGLIST_H doesn't help

TLF is version 0.9.23 and hamlib-dev is version 1.2.4-1.  The system is
a 1.2 GHz Celeron running Libranet 2.8.1 updated with packages from
Debian Sarge and Sid.

Any ideas?

TIA and 73,

Bob, N7XY

Bob Nielsen, N7XY                          n7xy (at)
Bainbridge Island, WA            

reply via email to

[Prev in Thread] Current Thread [Next in Thread]