[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Tlf-devel] Using TLF with hamlib

From: Rein Couperus PA0R
Subject: Re: [Tlf-devel] Using TLF with hamlib
Date: Wed, 04 May 2005 12:13:32 +0200

I have tlf-0.9.23 running without problem with hamblib 1.2.4 and the
ORION (rig nr. 1608). Also no problem with the K2.

my config.h says:

/* Define if you have the <hamlib/riglist.h> header file. */

/* Define if you have the <hamlib/rig.h> header file. */

/* Define if you have the <inttypes.h> header file. */

/* Define if you have the `hamlib' library (-lhamlib). */

Looks like tlf does not need riglist.h

Moreover, the error message you get is not from tlf, but from hamlib, so
I would look in that direction...

Anybody else have problems with the TS570D ?

Rein PA0R

On Mon, 2005-05-02 at 16:55 -0700, Bob Nielsen wrote:
> I finally got around to trying to interface my TS-570D to my computer.  
> It works fine with grig, but I haven't been able to get the rig to talk 
> to TLF.
> I ran configure with --enable-hamlib.  It appears to recognize hamlib:
> checking for main in -lhamlib... yes
> checking hamlib/rig.h usability... yes
> checking hamlib/rig.h presence... yes
> checking for hamlib/rig.h... yes
> enabling hamlib support
> However, checking the resultant config.h, I see:
> /* Define if you have the <hamlib/riglist.h> header file. */
> /* #undef HAVE_HAMLIB_RIGLIST_H */
> However, /usr/include/hamlib/riglist.h exists.
> I compiled TLF and enabled rig control in logcfg.dat, setting RIGMODEL, 
> RIGSPEED and RIGPORT to the appropriate values.  When I run TLF, I get 
> the following:
> Trying to start rig ctrl
> rig_open: error
> Editing config.h to define HAVE_HAMLIB_RIGLIST_H doesn't help
> TLF is version 0.9.23 and hamlib-dev is version 1.2.4-1.  The system is
> a 1.2 GHz Celeron running Libranet 2.8.1 updated with packages from
> Debian Sarge and Sid.
> Any ideas?
> TIA and 73,
> Bob, N7XY

reply via email to

[Prev in Thread] Current Thread [Next in Thread]