[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Tlf-devel] tlf & Ubuntu 9.04

From: Bob Nielsen
Subject: Re: [Tlf-devel] tlf & Ubuntu 9.04
Date: Wed, 23 Sep 2009 08:44:02 -0700

Hi Andy,

I tried commenting out the cluster part and tlf immediately quit with this message:

Reading logfile...
*** buffer overflow detected ***: tlf terminated

Joop is the Debian maintainer and I believe that Ubuntu's "universe" maintainers merely rebuild the packages from the Debian source. I just tried tlf 0.92.2-3 on a Debian 5.0 (lenny) machine and it didn't have the problem. I also compiled 0.9.30 (which I have used before) on the Sheevaplug and it gives the same error, so doesn't appear to be related to the tlf version. I suspect the problem I am seeing is related to the Marvell ARM processor, not Ubuntu, but will check later today on a computer running Ubuntu 9.04 with an AMD Athlon CPU.

73, Bob N7XY

On Sep 23, 2009, at 5:21 AM, Andy Summers wrote:


If you look here:

You'll see that Joop Stakenborg (of cwdaemon fame) is the Ubuntu package maintainer, so it might be a good idea to contact him.

It seems to me that the recent different versioning is down to specifically Ubuntu packaging improvements. I downloaded the source for tlf- from the Ubuntu repository and read /doc/README. It says the version is tlf-0.9.31-2. You can also find this out via "tlf -V" at the command line.

I also read the /ChangeLog file and noticed this:

2007-12-18      rein couperus <address@hidden>

        * changed cluster_bg.c to fix possible buffer overflow

I run tlf without the Cluster. I wonder if that's the difference. You could try disabling packet by commenting out all the packet lines in your logcfg.dat file, or by starting tlf with "tlf -n" (I think, from memory. It'll be listed in "man tlf" but not in the on- line version).

Good luck!
Andy, G4KNO.

On Wed, Sep 23, 2009 at 8:27 AM, Bob Nielsen <address@hidden> wrote: I tried the Ubuntu 9.04 tlf package as well as compiling 0.9.31-1 on my Sheevaplug (ARM processor) and get a different error with both of them:

*** buffer overflow detected ***: /usr/local/bin/tlf terminated

I don't know if there might be any ARM vs. i386 issues involved.

I see that Debian also has, which is apparently the same sou rce used by Ubuntu. The changelog indicates it is an upstream release, but I don't know where Rein has placed it.

73, Bob N7XY

On Sep 22, 2009, at 9:51 AM, Andy Summers wrote:

Hi Clyde,

I took a look at that reference. I'm confused that it quotes tlf-, but when I look at the source archive here http:// the latest is tlf-0.9.31-2?

I presume it's from the Ubuntu repository? Try compiling tlf-0.9.31-2 from source.

I'm using it (compiled) on Fedora 11 without problems.

Andy, G4KNO.

On Tue, Sep 22, 2009 at 12:05 AM, Clyde <address@hidden> wrote:
I could not find an answer to the posting referenced below.
I am experiencing the same problem.

73 Clyde K9JWI

Tlf-devel mailing list

Tlf-devel mailing list

Tlf-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]