[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Tlf-devel] voicekeyer tlf-1.1pre2 and other matters

From: Andy Summers
Subject: Re: [Tlf-devel] voicekeyer tlf-1.1pre2 and other matters
Date: Thu, 03 Nov 2011 19:58:39 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20110928 Fedora/3.1.15-1.fc14 Thunderbird/3.1.15

And again!

I remembered today also that when you arrow left when in the call field to edit some part of the call you just typed, the absence of a caret marker means you don't know where you are. Again you have to count the left arrow strokes to know.

73 Andy, G4KNO.

On 02/11/11 20:30, Andy Summers wrote:
Hi again,

I think your suggestion will work fine. Of course, ideally the code should figure out what sound options are available and pick an appropriate one automatically, but this could also be done in the shell script, I think. Best to get the basics working first though.

I used pre2 in CQWW and so now have some other comments. In the heat of the contest I didn't have time to investigate anything, so these are just things I noticed:

When you tab, spacebar or enter to get into the exchange field you see the caret positioned after the exchange, ready for you to backspace to correct if necessary. Anything you do after that point seems to lose the caret marker. In fact it looks like it's positioned up in the 'worked' window.

If I continue to hit tab when in the exchange field I expect it to cycle between the the call and exchange fields (that's what the manual says), but actually it toggles between the exchange field and the 'worked' window.

The two issues meant I had to escape to back up into the call field, but the number of times depends on whether you've also edited the exchange field. Without the caret marker you don't know which field you're currently in, so you can easily do too many escapes and erase the call entry all together.

I liked the bandmap, but again, if you've moved on to the exchange field ctrl-a doesn't work and you have to back-up. For some reason, at the start of the contest, stations I worked weren't added to the bandmap, but it suddenly started working later on.

Occasionally, the F1 message was actually playing the F6 message. A restart cured it. It sounds like something is stomping on a memory location? I'll keep an eye out in future for other things that are happening.

Can't think of anything else.

73 Andy, G4KNO.

On 02/11/11 19:43, Thomas Beierlein wrote:
Am Wed, 2 Nov 2011 11:05:56 -0700
schrieb Rob Vance<address@hidden>:

Hi Andy,

No apology required.  Yes, the short answer is that the sound card has
several microphone inputs but the names are different.  I'm not at the
machine now but I recall there are "front mic"&  "rear mic" of various
types, but none are called just plain "mic".

I should have reported back to Thomas:  Yes, commenting out the lines
solved the problem and the keyer worked as expected without any
complaints from amixer (in my code it was lines 1234 and 1236). It
was a very satisfactory work-around as I don't use other mic inputs
during contesting.
Hi Andy and  Rob,

nice to hear that my suggestion worked.

I will change the code in the next days to call one external shell
script for playback and provide an example. That shell script has to be
adapted by the user and can

- mute / unmute the mic,
- set the gain,
- play the file,
- set / drop any external/internal signal it needs to work with your
   hardware and
- do anything else you have to do.....

So the flexibility is in your hands without playing with the code.
What do you think?

Just to find some time for it ... (I hope at the weekend).

73, de Tom DL1JBE.

Alternatively I suppose I could have just renamed
the entries in lines 1234/1236 to match my sound card and thus had
the benefit of suppressing other sounds (mic inputs) during the voice
keyer operation; but I have not tried this.

Thank you so much for the updates to the scoring and bandmap; I am
still playing around with it, but I like it so far.

I have another question about the operation of the program, but I
will post that separately as it is quite different from this topic.



On Wed, Nov 2, 2011 at 10:32 AM, Andy Summers<address@hidden>


Sorry about that, it was my fault. I just sent my hacks, to get it
to do what I wanted it to do, over to Rein and they appeared in the
code. I'm not confident enough to add in a config option for using
the soundcard mic, so hopefully you might do that Tom? I presume
that's what's needed?

Can you really get soundcards without a mic input? Or is it just
called something slightly different on that soundcard?

73 Andy, G4KNO.

On Sat, Oct 29, 2011 at 7:39 AM, Thomas Beierlein<address@hidden>

Hi Rob,

Am Fri, 28 Oct 2011 21:45:04 -0700
schrieb Rob Vance<address@hidden>:
I am using tlf on 11.04 (Natty Narwhal).  It's working fine
except I am having a problem with the voice keyer.  When using
either the auto-keyer or an F-key to send an audio track, I get
this string on the screen.

amixer: Unable to find simple control 'Mic',0
TLF tries to mute the microfone input on your soundcard.

The problem lies in the hardcoded assumption that there is such an
input device on your soundcard.

I asked amixer to
give me a list of devices and discovered that there is none
called 'Mic' at all. So apparently tlf is calling a device
called 'Mic' and amixer is telling it there is no such device

If so, can someone
advise on a method to change this parameter?

As a quick fix I would suggest to comment out lines 1236 and 1238
in src/callinput.c and recompile. That will drop the amixer
invocation. Keep an eye to the possibility to catch additional
microfon input signals during sending of one of the F-key audio

73, de Tom DL1JBE

Hope everyone is enjoying CQ WW.


Rob, N6ROB

"Do what is needful!"
Ursula LeGuin: Earthsea

Tlf-devel mailing list

Tlf-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]