[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Two weirdnesses (bugs ?) in tramp 2.0.34

From: Gilbert Grosdidier
Subject: Re: Two weirdnesses (bugs ?) in tramp 2.0.34
Date: Thu, 14 Aug 2003 10:49:13 +0200 (CEST)

On Wed, 13 Aug 2003, Kai Großjohann wrote:

> Gilbert Grosdidier <address@hidden> writes:
> > - major problem is: when trying to "save" a file towards the remote host, 
> > it 
> > always take several 10's of sec. with the message 
> > "Waiting for remote host to process data" displayed in the minibuffer.
> What's the value of tramp-chunksize after you do that?

gg= This variable is "nil", both before and after a save.

> Does the time depend on the file size, or is it (more or less) the
> same for all files?  (If a twice-as-large file also takes twice as

gg= It does not seem to depend on file size, although they are always quite 

> long, we can hypothesize that the problem could be the transfer of
> the file contents; otherwise we need to look somewhere else.)
> Tramp is not /that/ slow for me.
> It takes a while to open a connection, but presumably the connection
> is already open when you are saving...

gg= IMHO, the connection is always already open when achieving a save:
I usually open a Xemacs session, then fetch a remote file,
edit and save several times over many hours ... Don't know what the exact
duty cycle of tramp is: is it re-opening a connection after some delay 
of "non-activity" ?



  Gilbert Grosdidier                 address@hidden
  [NOT At CERN NOW: Ext +41 22 767 4462 when at CERN (Room 31-S-024)]
  LAL / IN2P3 / CNRS                 Phone : +33 1 6446 8909
  Faculté des Sciences, Bat. 200     Fax   : +33 1 6446 8546
  B.P. 34, F-91898 Orsay Cedex (FRANCE)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]