[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp 2.1.4 install problem - bug or mis-configured?

From: Michael Albinus
Subject: Re: tramp 2.1.4 install problem - bug or mis-configured?
Date: Tue, 18 Oct 2005 22:30:45 +0200
User-agent: Gnus/5.110004 (No Gnus v0.4) Emacs/22.0.50 (gnu/linux)

Paul Lew <address@hidden> writes:

> Ok, this one is working except it put the info files under:
>     xxx/share/info
> directory instead of:
>     xxx/info
> where xxx default to: /usr/local.

Tramp's configure tries to be as standard conform as possible. From
the "GNU coding standards, last updated January 1, 2005":

     The directory for installing the Info files for this package.  By
     default, it should be `/usr/local/share/info', but it should be
     written as `$(datarootdir)/info'.  (If you are using Autoconf,
     write it as address@hidden@'.)  `infodir' is separate from `docdir' for
     compatibility with existing practice.

(Replace /usr/local with $prefix in our case).

> On my system, the xxx/info contain 697 entries, and xxx/share/info
> contains only 6 entries (just automake and tramp).  Not sure if
> this is desireable.

Tramp checks the existence of the potential info directories. If
xxx/share/info does not exist, it would check xxx/info as next candidate.

Nevertheless, if you apply "--infodir=\$prefix/info" during configure
it should be as desired.

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]