[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tramp-devel] Trying to debug remote gdb issue

From: Abhijeet More
Subject: Re: [tramp-devel] Trying to debug remote gdb issue
Date: Sun, 14 Oct 2007 14:53:21 -0400

On 10/14/07, Michael Albinus <address@hidden> wrote:
> I cannot reproduce the problem. Locally, I can use gdb for remote
> buffers without problems, and I see the source buffer.
> Do you have some special settings one should care? I simple scenario I
> could follow?

I have set up a few default transfer methods (external) for a few
boxes as an alist.
But I don't think that should affect this.

> > I looked into this and it seems to me that the problem is that the
> > function 'tramp-handle-file-exists-p' returns nil.
> > This calls the macro 'with-file-property' which should set the
> > property file-exists-p to t after fetching testing this on the remote
> > machine with 'test -e'. But it seems to just go ahead and set this
> > value without checking remotely (using tramp-set-file-property).
> > I am using edebug to step through the macro - however I don't quite
> > understand macros yet.
> Hmm. That's kind of caching Tramp uses internally. Hard to debug, I confess.
> The idea is that tramp-get-file-property is called first, which shall
> return the cached value. Only in case it returns 'undef, the body of
> with-file-property is evaluated, and the result is put into the cache via
> tramp-set-file-property.
I don't have access to my setup right now (its at work) - but as far
as I can remember - the body (that tries to fetch the correct property
remotely) doesn't get evaluated.
I shall take a look tomorrow and send you a trace.
On a side note - I would like to get involved in tramp development -
are there any small tasks / bugfixes that you can think of - that
would help me get a good grip on the source code ?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]