[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (2.1.19): Problem with tramp_vc_registered_read_file_names

From: Michael Albinus
Subject: Re: tramp (2.1.19): Problem with tramp_vc_registered_read_file_names
Date: Tue, 19 Oct 2010 22:27:02 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.50 (gnu/linux)

David Rothenberger <address@hidden> writes:

> The fix seems to work just fine.

Thanks for the feedback. My patch is a little bit rogue, I will try next
days to improve it.

> I generally build a package for Cygwin that I then install using
> it's installer. I had a few problems with my build script. I had to
> apply a patch to fix a build issue with "tramp-version" not being
> defined. The patch also builds and installs tramp-loaddefs.

tramp-loaddefs.el shall be build first, before compiling (there are
rules in the Makefile). Afterwards, tramp-version shall be defined.

Could you, please, check whether the following sequence works:

localhost:~/src/tramp> make distclean
localhost:~/src/tramp> autoconf
localhost:~/src/tramp> ./configure --with-xemacs --with-contrib
localhost:~/src/tramp> make

> Once I got the package and could load it, I did have a problem
> opening files, since "tramp-handle-call-process-region" was
> undefined. The second patch solved that problem for me.

Ah, that's an error, indeed. I have fixed it in the repository.

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]