[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Acl-devel] [PATCH acl 1/2] read_acl_{comments, seq}: rename "line" to "
From: |
Mike Frysinger |
Subject: |
[Acl-devel] [PATCH acl 1/2] read_acl_{comments, seq}: rename "line" to "lineno" |
Date: |
Sun, 19 Jan 2014 01:10:00 -0500 |
The word "line" is used to refer to the content of a line, and a few
places are already using "lineno". Change all to "lineno" so that we
can use "line" consistently.
---
tools/parse.c | 14 +++++++-------
tools/parse.h | 4 ++--
tools/setfacl.c | 10 +++++-----
3 files changed, 14 insertions(+), 14 deletions(-)
diff --git a/tools/parse.c b/tools/parse.c
index e7e6add..6f30cf5 100644
--- a/tools/parse.c
+++ b/tools/parse.c
@@ -407,7 +407,7 @@ fail:
int
read_acl_comments(
FILE *file,
- int *line,
+ int *lineno,
char **path_p,
uid_t *uid_p,
gid_t *gid_p,
@@ -439,15 +439,15 @@ read_acl_comments(
break;
if (c==' ' || c=='\t' || c=='\r' || c=='\n') {
if (c=='\n')
- (*line)++;
+ (*lineno)++;
continue;
}
if (c != '#') {
ungetc(c, file);
break;
}
- if (line)
- (*line)++;
+ if (lineno)
+ (*lineno)++;
if (fgets(linebuf, sizeof(linebuf), file) == NULL)
break;
@@ -539,7 +539,7 @@ read_acl_seq(
seq_t seq,
int seq_cmd,
int parse_mode,
- int *line,
+ int *lineno,
int *which)
{
char linebuf[1024];
@@ -552,8 +552,8 @@ read_acl_seq(
for(;;) {
if (fgets(linebuf, sizeof(linebuf), file) == NULL)
break;
- if (line)
- (*line)++;
+ if (lineno)
+ (*lineno)++;
cp = linebuf;
SKIP_WS(cp);
diff --git a/tools/parse.h b/tools/parse.h
index b2e68b4..2549753 100644
--- a/tools/parse.h
+++ b/tools/parse.h
@@ -61,7 +61,7 @@ parse_acl_seq(
int
read_acl_comments(
FILE *file,
- int *line,
+ int *lineno,
char **path_p,
uid_t *uid_p,
gid_t *gid_p,
@@ -72,7 +72,7 @@ read_acl_seq(
seq_t seq,
int seq_cmd,
int parse_mode,
- int *line,
+ int *lineno,
int *which);
diff --git a/tools/setfacl.c b/tools/setfacl.c
index f6135b7..b0ddedf 100644
--- a/tools/setfacl.c
+++ b/tools/setfacl.c
@@ -125,15 +125,15 @@ restore(
gid_t gid;
mode_t mask, flags;
struct do_set_args args = { };
- int line = 0, backup_line;
+ int lineno = 0, backup_line;
int error, status = 0;
int chmod_required = 0;
memset(&st, 0, sizeof(st));
for(;;) {
- backup_line = line;
- error = read_acl_comments(file, &line, &path_p, &uid, &gid,
+ backup_line = lineno;
+ error = read_acl_comments(file, &lineno, &path_p, &uid, &gid,
&flags);
if (error < 0) {
error = -error;
@@ -168,11 +168,11 @@ restore(
SEQ_PARSE_WITH_PERM |
SEQ_PARSE_DEFAULT |
SEQ_PARSE_MULTI,
- &line, NULL);
+ &lineno, NULL);
if (error != 0) {
fprintf(stderr, _("%s: %s: %s in line %d\n"),
progname, xquote(filename, "\n\r"),
strerror(errno),
- line);
+ lineno);
status = 1;
goto getout;
}
--
1.8.4.3
- [Acl-devel] [PATCH acl 1/2] read_acl_{comments, seq}: rename "line" to "lineno",
Mike Frysinger <=