[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Artanis] artanis fails on confgure to find guile

From: Java House
Subject: Re: [Artanis] artanis fails on confgure to find guile
Date: Mon, 13 Aug 2018 23:29:47 +0300


Thank you for your tips
I tried them but  pkg-config still cannot locate the guile 2.2

$ find / -name "guile-2.2.pc"
$ export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/guile-2.2.pc
$ pkg-config --exists --print-errors guile-2.2
Package guile-2.2 was not found in the pkg-config search path.
Perhaps you should add the directory containing `guile-2.2.pc'
to the PKG_CONFIG_PATH environment variable
Package 'guile-2.2', required by 'virtual:world', not found

both guile and artanis latest versions are downloaded from the recomended git repository.
I installed and used gmake on FreeBSD and I was using gmake while building guile.
I placed all the steps I followed for building and installing guile under FreeBSD here

any more ideas?

Kind Regards

Στις Σάβ, 11 Αυγ 2018 στις 2:17 π.μ., ο/η Julio Claudio Matus Ramirez <address@hidden> έγραψε:

Hello Nikolas,

So, you tried to install artanis with guile 2.2.4 right?

Please try the command:

pkg-config --exists --print-errors guile-2.2
(configure does something like this to check your guile version)

And see you don't get any errors.
If this worked then you can ignore the rest of this email...

If not,
I'm guessing your pkgconfig path is not the default one so you need to
declare it before running configure.

Mine looks like:
export PKG_CONFIG_PATH=/home/XXX/bin/lib/pkgconfig

Yours might be /usr/local/lib/pkgconfig ?
You can check by:

find / -name "guile-2.2.pc"

And use that dir path.


Java House <address@hidden> writes:

> Hello
> totally new in Gnu Guile and artanis.
> I am trying for the last couple of weeks to setup guile and artanis my local environment.
> I finally manage to build guile using the latest from git 2.2.4
> I am following instruntions from here
> but ./configure fails to fins guile even though it has been installed.
> I downloaded artanis and then run
>     $ ./
>     aclocal -I m4
>     autoconf
>     Now try ./configure
>     $ ./configure
>     checking for a BSD-compatible install... /usr/bin/install -c
>     checking whether ln -s works... yes
>     checking whether make sets $(MAKE)... yes
>     checking for pkg-config... /usr/local/bin/pkg-config
>     checking pkg-config is at least version 0.9.0... yes
>     configure: checking for guile 2.2
>     configure: checking for guile 2.3
>     configure: checking for guile 3.0
>     configure: error:
>     No Guile development packages were found.
> guile has been built and installed succesfully (after alot of effort)
>     $ find / -name guile 2> /dev/null
>     /usr/home/nikolas/Downloads/guile
>     /usr/home/nikolas/Downloads/guile/libguile/.libs/guile
>     /usr/home/nikolas/Downloads/guile/libguile/guile
>     /usr/home/nikolas/Downloads/guile/meta/guile
>     /usr/home/nikolas/Downloads/guile-2.2.4/libguile/.libs/guile
>     /usr/home/nikolas/Downloads/guile-2.2.4/libguile/guile
>     /usr/home/nikolas/Downloads/guile-2.2.4/meta/guile
>     /usr/local/bin/guile
>     /usr/local/lib/guile
>     /usr/local/include/guile
>     /usr/local/share/guile
>     /usr/ports/lang/guile
> I have also built 
> guile-dbi-guile-dbd-postgresql-2.1.6
> guile-dbi-guile-dbi-2.1.6
> I am running FreeBSD
> # uname -a
> FreeBSD drake 11.2-RELEASE FreeBSD 11.2-RELEASE #0 r335510: Fri Jun 22 04:32:14 UTC 2018     address@hidden:/usr/obj/usr/src/sys/GENERIC  amd64
> Any help or reference is aprreciated.
> Kind Regards
> Nikolas

address@hidden (XMPP/mail)
GPG key:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]