[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX-devel] Install report: XEmacs and Windows XP

From: David Kastrup
Subject: Re: [AUCTeX-devel] Install report: XEmacs and Windows XP
Date: Wed, 11 Oct 2006 14:38:31 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

Going through backlogs now.

Michael Forster <address@hidden> writes:

> [ Sorry about the double posting. I wanted to send that to
> auctex-devel, but in error sent it to auctex-general ]
> Please note, that the following is not meant as a rant, but rather as
> a guide, where the install story could be improved. I am sure that
> most other Windows users would have given up much earlier.
> ======================================================================
> I did the following, starting on 2005-05-16 10:15 (+10:00):
> 1) O.k., so I thought, I'd start with a freshly installed XEmacs,
> without the risk of something being screwed up. So I moved away my
> ~/.xemacs directory and downloaded the newest XEmacs (21.4.13) using
> the net installer
> and native install. XEmacs/Windows currently comes with AUCTeX 1.46,
> so I deselected that. No problems. MikTeX is not reinstalled.
> 2) Check out AUCTeX from CVS using TortoiseCVS. No problems.
> 3) Where's the install documentation? README.CVS: run Ok,
> Standard. What else? RELEASE? No install documentation.

The installation documentation is generated by  README.CVS
starts with

    If you retrieved AUCTeX via CVS instead of as a regular release,
    there are some files that need to be generated from their
    respective source files before you can continue reasonably with
    the instructions detailed in the README and INSTALL files (which
    will not be present otherwise).

The respective lines date from May 2005, so they probably are a result
of your report.

> Ah!, doc/install.texi and doc/wininstall.texi. TeXinfo source? Well,
> probably my fault, because I got it from CVS.
> 4) Let's start with wininstall.texi. MSYS or CygWin is needed? O.k. I
> have Cygwin installed. Let's use that. XEmacs, MikTeX and Perl are
> installed, so all prerequisites are fine.
> 5) Error:
> ---------------------------------------------------------------------------
> makeinfo preview-latex.texi
> ' in @synindex.exi:11: Unknown index `vr' and/or `cp
> ' in @synindex.exi:12: Unknown index `ky' and/or `cp
> ' in @synindex.exi:13: Unknown index `fn' and/or `cp

Outdated version of makeinfo.  Note that in the non-CVS release
tarballs, makeinfo is not called nowadays if you did not touch the
source files.

> Now it works. Ah! Now there's also the file. Fine! But
> the line breaks are screwed up:
> ---------------------------------------------------------------------------
>   1. If you unpacked the distribution using Winzip or similar, you
>      better
>  restart using infozip on the `.zip' file, or standard
>      Unix tools
>  (see the next point) on the `.tar.gz' file: tools
>      that make the
>  mistake of turning Unix line endings into MSDOS
>      line endings will cause
>  trouble later in installation and
>      operation.

Outdated version of makeinfo.

> Hm, I'll stay with wininstall.texi. Seems to be the same, anyways.


> 6) Now, how do I call configure? I'll probably need --prefix? What's
> the correct path for prefix? Probably "C:\Program
> Files\XEmacs". wininstall.texi said to use the C: syntax with forward
> slashes and to avoid spaces. I try to be clever here and use
>     ./configure --prefix=C:/Progra~1/XEmacs
> XEmacs package directory not found. Hm. configure could have been more
> clever.
>     ./configure \
>       --prefix=C:/Progra~1/XEmacs \
>       --with-packagedir=C:/Progra~1/XEmacs/xemacs-packages starts nowadays with a short introduction including
the command lines to be used for "Program Files"-based folders.

> Ghostscript not found? Did the install documentation mention that?
> Must have missed that. Well, I have Ghostscript installed. How do I
> tell this to configure? I don't want to put it in the path.

Why not?

> Ah preview/ mentions it. Difficult to find. This
> should be in the top-level
>     GS="C:/Progra~1/Ghostscript/gs8.50/bin/gswin32.exe" \
>     ./configure \
>       --prefix=C:/Progra~1/XEmacs \
>       --with-packagedir=C:/Progra~1/XEmacs/xemacs-packages

It is.  Seems to be also a reaction to your report, judging from the

> Same error! What? From where does configure put up the ~1??? Ah! My
> Path.

Why would one put ~1 components in the PATH?

> Summary of things, I'd like to see fixed:
> a) Handling of spaces in path names is subomptimal. Yes, I know, the
> INSTALL file says: Don't use spaces. Unfortunately "C:\Program
> Files" is the standard on Windows. Like it or not, but I won't
> install any software in non-standard places. If a software does not
> work with "C:\Program Files" I at least expect "C:\Progra~1" to
> work. If this is not the case, I won't use the software.

Should be improved to a level where you would not complain.

> b) Fix compile error in preview-latex.texi

Update makeinfo, or use a release tarball.

> c) Fix screwed line breaks in

Update makeinfo, or use a release tarball.

> c) Move all relevant install information to the top-level

It pretty much contains all relevant install information.

So even so this mail does not seem to have been answered, I think that
most of your complaints have been addressed in the mean time.

David Kastrup, Kriemhildstr. 15, 44793 Bochum

reply via email to

[Prev in Thread] Current Thread [Next in Thread]