[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX-devel] problems with make install for auctex-11.84 with XEma

From: Ralf Angeli
Subject: Re: [AUCTeX-devel] problems with make install for auctex-11.84 with XEmacs on WinXP
Date: Fri, 21 Dec 2007 07:56:45 +0100

Please keep the mailing list copied.  I am doing a full quote for

* Daniel Winkelmann (2007-12-20) writes:

> Ralf Angeli wrote:
>> * Daniel Winkelmann (2007-12-20) writes:
>>> during the installation of XEmacs I also checked the box for AUCTeX
>>> but
>>> when I opened a *.tex file the LaTeX and Command menus didn't appear
>>> in
>>> XEmacs.
>> This is not a big loss since the version of AUCTeX distributed with
>> XEmacs is ancient anyway.
>>> I downloaded and followed the instructions as best I
>>> could to install with configure and make in a cygwin bash:
>>> address@hidden /cygdrive/d/auctex-11.84
>>> $
>>> ./configure --prefix="D:\\XEmacs"
>>> --with-xemacs="/cygdrive/d/XEmacs/XEmacs-21.4.21/i586-pc-win32/xemacs.exe"
>>>  --with-packagedir="D:\\XEmacs\\xemacs-packages"
>>> --with-auctexstartfile="auctex.el"
>>>  --disable-preview
>> Not sure if this is the cause, but using forward slashes instead of
>> backslashes is usually safer.
>>> configure ran without problems
>>>  (using
>>> --with-xemacs="D:\\XEmacs\\Xemacs-21.4.21\\i586-pc-win32\\xemacs.exe"
>>> did not work)
>> What means "did not work"?
> the configure script complained that it can't find xemacs and stopped
>>> make also ran without problems
>>> but make install in the end (how far from the and am I?) produced the
>>> following error message
>>> make[1]: *** [install-metadata] Error 255
>>> make[1]: Leaving directory `/cygdrive/d/auctex-11.84'
>>> make: *** [install] Error 2
>> What does the output show just before the error?  Can you debug which
>> command in the `install-metadata' target fails?
>>> Still no LaTeX nor Commands menus, LaTeX mode works, so I have syntax
>>> higlighting and I can call pdflatex as a shell command but AUCTeX
>>> should
>>> give me much more, right?
>> Right.
>>> cygwin with non-cygwin xemacs is a problem ? yes, at least in my case
>>> but I couldn't tell you why. Maybe you can tell me.
>>> ok, so I try MSYS
>>> here
>>> --with-xemacs="D:\\XEmacs\\Xemacs-21.4.21\\i586-pc-win32\\xemacs.exe"
>>> and
>>> --with-xemacs="D:/XEmacs/Xemacs-21.4.21/i586-pc-win32/xemacs.exe"
>>> both work and I hope that my problems will be gone, but  the last
>>> lines
>>> of make install RET read:
>>> Generating autoloads for tex-info.el...
>>> Generating autoloads for tex-jp.el...
>>> Unbalanced parentheses
>>> xemacs exiting
>>> .
>>> make[1]: *** [install-metadata] Error 1
>>> make[1]: Leaving directory `/d/auctex-11.84'
>>> make: *** [install] Error 2
>>> my fault or not ? any help is appreciated
>> Hm, does your XEmacs claim to have MULE support?  When you run
>> `configure' there is somewhere output like "checking for MULE
>> support".  What's the result of this test?
> Thank you  for your time,
> the result is no MULE support
> after a dinner break I found advice you had given to somebody else :
>> Ralf Angeli wrote:
>>> Instead of using
>>>  --with-packagedir='C:/Apps/XEmacs/xemacs-packages/'
>>> you should use
>>>  --with-packagedir='C:/Apps/XEmacs/site-packages/'
> and I ran configure again with MSYS
> ./configure --prefix="D:/XEmacs" 
> --with-xemacs="D:/XEmacs/XEmacs-21.4.21/i586-pc-win32/xemacs.exe"
>  --with-packagedir="D:/XEmacs/site-packages" 
> --with-auctexstartfile="auctex.el" 
>   --disable-preview
> again configure and make worked without complaint but make install 
> finishes with the same errors but not the "unbalanced parentheses"

How can it finish with the same errors if the error about unbalanced
parentheses is missing?

> and when I open a *.tex document with Xemacs I now do get the menus. I 
> dont' kow yet if other things will fail to work because install didn't 
> finish.

Me neither.  But you should stay clear of UTF-8 files with a no-MULE

> should I run make install again?

You will likely get the same errors, so I doubt this will help.

> should I send you config.log ?

Yes, it might give some hints.

> install 
> doesn't seem to write a log and I don't know how to  cut and paste out 
> of  the MSYS window.

You can use `tee' to redirect the output to a file.  I currently don't
have time to look up the syntax, nor do I know if it is included in
MSYS.  Especially the error messages at the bottom are essential for
debugging.  Without those config.log will not help much.

BTW, if you want to be sure to have a fully working AUCTeX, you could
download the AUCTeX XEmacs package from the AUCTeX homepage and simply
drop this into your package tree.  This will spare you the hassles of
configuring and building.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]