[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[AUCTeX] Package doesn't recognize my Fink teTeX installation

From: Chad Groft
Subject: [AUCTeX] Package doesn't recognize my Fink teTeX installation
Date: Sun, 8 May 2005 17:21:05 -0700

Hi! I hope someone on this list can help me get AUCTeX and preview- latex working.

I'm on a Mac, currently using OS X 10.4, and I use Fink for a number of packages, including ispell and teTeX. I did not install Emacs through Fink, however, because they're stuck on version 21.2 and I don't care for the X11 interface. Instead, I've installed the Carbon version of Emacs, which functions as a standalone Mac application. I've also installed AUCTeX manually, to work with this version of Emacs -- and it does, except that it doesn't find my teTeX installation. (For the record, I installed all of these just yesterday, including the CVS version of Emacs, so they should be up to date.)

The general problem is that Fink installs its packages into a separate directory /sw/bin, which is not included in the usual $PATH. Fink's setup includes creating a file called ".profile" in my home directory which adds /sw/bin (among others) to $PATH when I work in Terminal. Emacs, though, doesn't look at this file at all, and thus doesn't normally see the outside utilities.

In the case of ispell, I was able to fix this by modifying the exec- path variable through the customize utility. teTeX is a bit different; emacs tries to invoke these programs by starting a shell, one which looks at .bashrc instead of .profile. I simply made .bashrc a hard link to .profile, which fixed the problem -- *if* I don't load AUCTeX. If I do, I get an error of the form "LaTeX exited abnormally with code 127" etc., which it seems means that LaTeX never actually started.

AUCTeX, it appears, also starts a shell to invoke the teTeX programs, but it starts one with the command-line option -c -- which causes the shell to ignore .bashrc and all other startup scripts, and thus makes it difficult to get the $PATH right. It seemed that the best bet was to hack AUCTeX to somehow invoke .bashrc or .profile before running latex or so forth, but I don't see how. I tried changing the string in the definition of TeX-shell from "/bin/sh" to "/bin/bash", and I tried changing the string in TeX-shell-command-options from "-c" to ""; neither of these worked.

Has anyone been able to get this method to work? Does someone possibly have a more elegant method? And does anyone know of additional issues with preview-latex (just in case)?


Chad Groft        address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]