auctex
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] font lock user-defined commands


From: Hans Halvorson
Subject: Re: [AUCTeX] font lock user-defined commands
Date: Fri, 06 Jul 2007 08:06:53 -0400
User-agent: Wanderlust/2.15.5 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.8 (Shij┼Ź) APEL/10.7 Emacs/22.1.50 (i686-pc-linux-gnu) MULE/5.0 (SAKAKI)

Ralf,

Thanks for the quick response.

I had snipped the initial quote, and I had restarted emacs.  Now it
works after changing one more thing: I changed
 
 '(font-latex-match-bold-command-keywords '("defin"))

to

 '(font-latex-match-bold-command-keywords (quote ("defin")))

I think this must be a coincidence; something else must have changed.
I probably should not have manually edited my custom variables!

Thanks,
Hans

At Thu, 05 Jul 2007 23:13:19 +0200,
Ralf Angeli wrote:
> 
> * Hans Halvorson (2007-07-05) writes:
> 
> > As a test, I am trying to get "\defin" to highlight.  I have tried
> > both of the following in the custom variables in my .emacs:
> >
> > (font-latex-user-keyword-classes (quote (("defin" ("defin") (:foreground 
> > "cyan") (command 1)))))
> 
> In case you produced this via Customize it looks okay except for the
> missing quote at its start which you probably snipped.
> 
> > (font-latex-match-bold-command-keywords '("defin"))
> >
> > Neither of these is making any difference -- "\defin" and
> > "\defin{foobar}" are still showing up in light gray.  What am I doing
> > wrong here?  (I am running AucTeX 11.84 on Emacs CVS 22.1.50.)
> 
> Did you restart Emacs after saving the customization?
> 
> -- 
> Ralf




reply via email to

[Prev in Thread] Current Thread [Next in Thread]