[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[AUCTeX] Problem with getting reftex to start

From: Torben Hoffmann
Subject: [AUCTeX] Problem with getting reftex to start
Date: Sun, 30 Sep 2007 00:56:16 +0200
User-agent: Thunderbird (Windows/20070728)


I have tried to use the AucTEX/Preview-LATEX + RefTEX configuration from in my .emacs, and it does not quite work: AucTeX seems to load just fine and the regular shortcuts like C-c C-s does work.
However, the Ref menu does not appear before I do a M-x reftex-mode which is rather annoying.

I have even installed the AucTeX/Emacs bundle instead of my regular XEmacs installation (which I have messed up in the process :-() in order to get this to work, but to no avail.

Here's a short extract from my .emacs file:
(setq TeX-auto-save t)
(setq TeX-parse-self t)
(setq-default TeX-master nil)

(require 'reftex) 
(add-hook 'LaTeX-mode-hook 'turn-on-reftex)
(setq reftex-plug-into-AUCTeX t)
;; (setq-default TeX-header-end nil)
;; (add-hook 'TeX-mode-hook '(lambda () (TeX-fold-mode 1)))
;; (add-hook 'LaTeX-mode-hook 'LaTeX-install-toolbar)
(require 'tex-mik)
As I said I have also tried with the all the line uncommented and without  the (require 'reftex) line - does simply not work!

Any clues?!?!

Torben Hoffmann
Group Leader Phone: +45 43 48 81 16
Prototype Developer & STG Driver Mobile: +45 25 40 81 16
There must be more to life than having everything - Maurice Sendak
Did you ever stop to think, and forget to start again? - A.A. Milne
You miss 100% of the shots you don't take. - Wayne Gretzky
Quality means doing it right when no one is looking. - Henry Ford

reply via email to

[Prev in Thread] Current Thread [Next in Thread]