[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[AUCTeX] Re: Installing on Mac OS X 10.5 with self-contained Emacs 23.2

From: Ricardo Hernandez
Subject: [AUCTeX] Re: Installing on Mac OS X 10.5 with self-contained Emacs 23.2
Date: Thu, 5 Aug 2010 23:31:57 +0000 (UTC)
User-agent: Loom/3.14 (

Ralf Angeli <angeli <at>> writes:

> * Otto Maddox (2010-07-13) writes:
> > I've installed Emacs 23.2 as a self-contained application (i.e., using
> > --with-ns during configuration). So nothing weird. Now I'm having
> > difficulty finding the right configure options for AUCTeX 11.86 . I
> > tried "./configure
> > --with-emacs=/Applications/" and got
> >
> > checking where lisp files go... configure: error: Cannot locate lisp
> > directory,
> > use  --with-lispdir, --datadir, or possibly --prefix to rectify this
> >
> > Why can't configure determine automatically where to put the lisp files,
> > info documentation, etc?
> Probably because none of the active AUCTeX developers owns a Mac.  But I
> think even when installing for Emacs under Windows configure does not
> find all directories by itself.  In the top-level Makefile of AUCTeX
> there is a target for the precompiled AUCTeX package for Windows and the
> configure call looks like this:
> ./configure --prefix=$(WBUILDDIR)/emacs-$(WEMACSVER) \
>   --without-texmf-dir --with-emacs=$(WEMACS) \
>   --with-lispdir=$(WBUILDDIR)/emacs-$(WEMACSVER)/site-lisp \
>   --datarootdir=$(WBUILDDIR)/emacs-$(WEMACSVER) \
> Something along those lines might work for you as well if you exchange
> the variables with proper values for your system.

It has been a while, so you may have already figured this out.

./configure \ --with-emacs=/Applications/
\ --with-lispdir=/Applications/ \

This gets AUcTeX to compile nicely but, in my case, it was still
unusable in Emacs.

Interestingly enough, i used the -with-emacs=dir option with just one
hyphen in front of it and ./configure did not complain. I'm new to OS X,
so I'm not sure if it's supposed to work that way or if it's a bug.

I posted pretty much your same question in another site and documented
my way through the problem in the answers. Here's the link:

In short:

You need to call AUCTeX from your .emacs file, as per the manual. This
will add the appropriate hooks for when you open a .tex file, but you
will not be able to latex it if you called Emacs from the Finder. (If
you called it from the terminal, it will work). To be able to do that
you have to create the ~/.MacOSX/environment.plist file (case sensitive)
and paste the following into it. 


 <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC
"-//Apple//DTD PLIST 1.0//EN"
"";;> <plist version="1.0">
<dict> <key>PATH</key>
/usr/local/texlive/2009basic/bin/universal-darwin</string> </dict>


I found this last bit at:

This solved the problem for me.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]