[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] TeXLive2011 Biber environment problem

From: Haines Brown
Subject: Re: [AUCTeX] TeXLive2011 Biber environment problem
Date: Thu, 18 Aug 2011 10:23:38 -0400
User-agent: Mutt/1.5.20 (2009-06-14)

Guilhem, you corrected me on a major point. I had assumed that 
biblatex was deprecated by biber and so its manual would be 
irrelevant. I see that this is not so.

On Wed, Aug 17, 2011 at 10:02:56PM +0200, Guilhem Bourrié wrote:

> In your .tex file, you must have a command such as:
> ...
> \addbibresource{/Users/haines/<pathname of your .bib file>/<mybiblio>.bib}
> ...

I didn't understand the syntax here (in Debian, the root directory is 
/home, not /Users). My .bib resource in in ~/jabref/ and so I tried: 


However, this jabref/ location is already in my enviornment:

  $ echo $BIBINPUTS

So can the \addbibresource command instead simply be:


But my environment problem seems to be much deeper than this. With a 
test.tex file that accords (I believe) with the biblatex manual, when 
I run the latex command on it I get:

  ERROR: LaTeX Error: File `biblatex.sty' not found.
    --- TeX said ---
  Type X to quit or <RETURN> to proceed,
  or enter new name. (Default extension: sty)

  Enter file name: 
  ! Emergency stop.
  <read *> 
  l.11 \addbibresource
  --- HELP ---
  From the .log file...

  *** (cannot \read from terminal in nonstop modes)

I'm not sure what all this means, but it seems that biblatex needs to 
find a biblatex.sty file and failed to do so. 

A possible cause of this error is that biblatex is not installed, but 
it is installed and I do have the file:

  $ locate biblatex.sty

However my environment is:

  $ echo $TEXINPUTS

Should I instead have defined the environment to be 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]