[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] auctex Digest, Vol 85, Issue 11

From: Benjamin Slade
Subject: Re: [AUCTeX] auctex Digest, Vol 85, Issue 11
Date: Mon, 26 Mar 2012 15:52:21 -0500

Hi Tassilo,

Ok, I tried that -- and I don't get any memory leak.

But in my usual setup, not loading preview has definitely fixed the memory leak I was seeing in Emacs 23 (though, again, I still have problems with 24). 

So I'm guessing preview in combination with something else causes the leak for me. But what the something else is isn't clear to me. I thought it might be flyspell, but I tried only loading auctex, preview and flyspell, and I still didn't get a leak.


Date: Mon, 26 Mar 2012 10:20:53 +0200
From: Tassilo Horn <address@hidden>

Hi Benjamin,

> After turning on and off various things in my .emacs, I finally
> "fixed" the leak, by disabling "preview"
> (Specifically by commenting out:
> ; (require 'preview-latex)
> ; (load "preview-latex.el" nil t t)
> )

Why did you require it and then load it again?  But anyway, simply
loading preview but not using it shouldn't have a major effect on

> I don't use preview anyway, so this is a fine solution for me.  I'm
> not quite sure why preview is causing the leak, though I suspect
> perhaps there's something idiosyncratic (and wrong) about my .emacs
> setup.

Hm, I usually don't use preview, too.  But I've just tested it on some
document including at least some math formulas and some images, and it
works fine.  When I do M-x preview-document, the preview images are
generated into somy my-doc.prv/ subfolder and inserted into the document
buffer.  At that point, the memory usage increases a bit.  But shortly
after I do M-x preview-clearout-buffer and all preview images are
removed, memory seems to be returned back and the emacs process consumes
about the same as before...

> Also, this also plugged the leak under GNU Emacs 23. I tried the
> snapshot of Emacs 24, and I still have a leak there (though I don't
> think it's AUCTeX-related).

Could you try to reproduce the leak starting with "emacs -Q", adding
this to *scratch* and evaling it (C-x C-e after the closing paren)?

--8<---------------cut here---------------start------------->8---
 (add-to-list 'load-path "path/to/auctex/")
 (load "auctex.el" nil t t)
 (load "preview-latex.el" nil t t))
--8<---------------cut here---------------end--------------->8---


reply via email to

[Prev in Thread] Current Thread [Next in Thread]