[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] SyncTeX problems

From: Julien Cubizolles
Subject: Re: [AUCTeX] SyncTeX problems
Date: Mon, 27 May 2013 17:20:24 +0200
User-agent: Gnus/5.130008 (Ma Gnus v0.8) Emacs/24.3.50 (gnu/linux)

Tassilo Horn <address@hidden> writes:

>   $ git clone git://
>   $ cd auctex
>   $ ./configure
>   $ make

> (add-to-list 'load-path "~/Repos/el/auctex/")
I was only using the above line to choose the git version of AucTeX
> ;; below your usual AUCTeX configurations

I also added
(setq  TeX-source-correlate-mode t)
(setq TeX-source-correlate-method 'synctex)

At the moment, choosing TeX-evince-sync-view asks the permission to
start Emacs server but still doesn't launch evince, without any
information in *Messages*

If I launch evince for the pdf file, 

* running TeX-evince-sync-view (forward-search if I'm not mistaken)
  doesn't update the page shown in evince

* Ctrl-left click (backward-search) in evince does indeed change the
  point in the Emacs buffer. The position was the right one when I tried
  a one file document but a wrong one when I tried a multifile.

* finally, if I run LaTeX on a region (C-c C-b or C-c C-r),
  backward-search returns to the _region_.tex buffer. Is it possible to
  return to the original fileĀ ? I guess it's not straightforward to get
  the right position in the buffer.

Thanks for your help.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]