[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] how to use the git repository to obtain the latest aucTeX?

From: Nicolas Richard
Subject: Re: [AUCTeX] how to use the git repository to obtain the latest aucTeX?
Date: Thu, 05 Sep 2013 11:32:17 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux)

David Kastrup <address@hidden> writes:
> There is even a section "Advice for the non-privileged user" that goes
> into considerably more detail for this use case.
> Why don't people read it?  Why don't they reference it?  Maybe AUCTeX
> should not use any fallbacks but just refuse to do anything when people
> tell it to install to a hierarchy that they don't actually place into
> their load-path or similar.

I'll try to answer from my own experience.

I remember I found it difficult to find the right set of options,
because the meaning of each wasn't super clear[*] (probably because I
am/was not enough used to the emacs or tex parlance) and I didn't know
which ones I had to specify.

Now that I have just re-tried installing, I think the real problem was
that the above was combined with the fact that I can't use the usual
shortcut ~ in my paths :

Example 1:
$ ./configure --prefix=~ --with-lispdir=~/elisp --with-texmf-dir=~/texmf
configure: error: expected an absolute directory name for --prefix: ~

Example 2:
$ ./configure --prefix=/home/test --with-lispdir=~/elisp 
configure: error: --with-texmf-dir="~/texmf": Directory does not exist

ah ha !

Example 3:
$ ./configure --prefix=/home/test/ --with-lispdir=/home/test/elisp 

That worked (well, 'make' and 'make install' went with no apparent errors, I
didn't really try if the installation was fully working)

Error in example 2 is particularly unhelpful, although having seen the
error in example 1, I should have realized what was wrong (~ is in fact
an absolute path). Is this something specific with my install that ~
isn't recognized properly ?

Also, I take the opportunity to mention this kind of messages from ./configure:
   checking where the data files go... ${datadir}/emacs/site-lisp/auctex
but the value of ${datadir} isn't shown on screen (well, I can read that
config.status, but that's not very friendly)

[*] Example of things that probably were unclear to me when I first
tried (I'm reading the configuration options from the INSTALL file):
- site-lisp, site-start.d and site-start.el ??
- auto dir ? which generated files ?
- do I need --with-packagelispdir or not ?
- --with-texmf-dir, is it where auctex will put files, find files, or
  both? (I think the answer is : it's used for writing/putting files)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]