[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Success (mostly) with the testsuite

From: David Morgan
Subject: Re: Success (mostly) with the testsuite
Date: Fri, 13 Oct 2000 10:57:38 -0700

Akim Demaille wrote:
> | tools.m4:164 ignored near `tools.m4:183'
> |
> | I'm not sure what to do with the ignored as I got some on my Linux box as 
> well.
> No problems.
> | I also tried on a QNX box (our torture test box for building our products)
> |
> | The configure script bombs out while creating config.status with a message
> |  sed: 2:
> |          /^X\(.*^/\)\/\/*^ ...": RE error: parentheses not balanced
> |
> | So it looks like we need some work on the RE's for a bad sed :(
> Big problem.
> Could you try to ``define'' exactly the nature of the problem (i.e.,
> find a small command line that demonstrates the problem).
Ok based on some simple tests so far the first failure is:

echo "X"$ac_file"" | sed '
    /^X\(.*^/\)\/\/*^/^/*\/*$/{ s//\1/p; q; }'

I ran some more tests and have

echo "X"$ac_file"" | sed '/^X\(.*\)/{ s//\1/p; q; }'

working (returns tests/atconfig)

echo "X"$ac_file"" | sed '/^X\(.*^/\)/{ s//\1/p; q; }'

Fails reporting RE error: parentheses not balanced

This is getting beyond my experience of sed.

The man page for the sed I am using can be found at:

If there is more I can do let me know.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]