[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Autoconf testing results.

From: Pavel Roskin
Subject: Autoconf testing results.
Date: Tue, 27 Feb 2001 01:18:12 -0500 (EST)


Here are some results. I didn't try to investigate the problems. Instead
I tried to get a general picture.

   RedHat Linux 7.0
bash-2.04: ok

   RedHat Linux 6.2
bash-1.14.7: ok (very rare intermittent failure).

There was one failure that couldn't be reproduced. But I see such things
approximately once in 10 testsuite runs. It looks like a race condition in
bash. Few weeks ago I managed to capture the log of the problem - bash
printed something like "cannot open fd 8 for command substitution" to

zsh, pdksh, ash-0.3.7: ok

ash-0.2: failed

ash-0.2 cannot run configure because it crashed on string constants longer
that 1024 bytes. The first trap in configure uses a longer string. Also
ifnames cannot be run by ash-0.2 for the same reason.

   FreeBSD 4.0:
native /bin/sh: ok

   QNX Neutrino:
native /bin/sh: not fully tested.

Most tests are ignored because gcc cannot create executables. I admit that
it can be true - I've never tried.

   BeOS Personal edition 5.01:
native bash: failed

Since PATH begins with ".", configure finds m4 which is a directory:
checking for m4 ... ./m4

and fails because it cannot create frozen files. After giving it the
right M4, configure and make work. However, all tests involving autoupdate
fail because Perl is missing. They shouldn't fail, they should be ignored.


The issues with BeOS should be easy to fix. Probably Autoconf 2.49b should
not be released until they are fixed.

The issues with ash-0.2 can be worked around by creating temporary files,
but I doubt whether we should do it.

Pavel Roskin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]