[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Behaviour differs at configure time

From: Andre Caldas
Subject: Behaviour differs at configure time
Date: Wed, 20 Jul 2005 10:02:18 +0900
User-agent: Debian Thunderbird 1.0.2 (X11/20050602)

Hello, All!

I have these lines in my

AC_CHECK_LIB( pthread, [pthread_create] )
        [We will use posix threads]) ] )
AC_CHECK_FUNCS( pthread_yield pthread_mutexattr_settype )

I am cross-compiling (--host=arm-linux).

When I run the configure script it checks for pthread_mutexattr_settype and finds it. But when I do a "make", I get an error saying that this function is not defined.

Well, the function is protected by a "#ifdef __USE_UNIX98". I guess this is the source of my problem. Why would that be defined during configure and not during make?

I don't have any environment vars set that would affect this, I belive. I did this:
        set | grep FLAG
and got nothing.

I run configure like this:
~/project/configure --prefix=~/usr --disable-static 'CXXFLAGS=-O3 -g0 -Wall -pedantic-errors -Wno-long-long -Woverloaded-virtual'

Thank you,
Andre Caldas.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]