[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: autoconf test failures - how to react?

From: Paul Eggert
Subject: Re: autoconf test failures - how to react?
Date: Thu, 04 May 2006 09:52:45 -0700
User-agent: Gnus/5.1008 (Gnus v5.10.8) Emacs/21.4 (gnu/linux)

That latest failure looked like this:

12. testing ...
./ autoupdate --version | sed 's/.*) //;q'
./ echo "AC_PREREQ(1.0)" | autoupdate -
./ echo "AC_PREREQ($autoupdate_version)" | autoupdate -
./ echo "AC_PREREQ(999.99)" | autoupdate -
/tmp/au822.1499/stdin:1: error: Autoconf version 999.99 or higher is required
/tmp/au822.1499/stdin:1: the top level
autoupdate: failed to run /bin/m4: Invalid seek on non-seekable object

This error message comes from Perl, and makes it look like the Perl
system function cannot run /bin/m4.  That sounds like an error in your
setup somehow.  Still, it is a bit odd that the other tests succeeded,
whereas this one failed.  Perhaps you can investigate it more?
Perhaps Perl cannot run system("echo foo | /bin/m4")?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]