[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: m4_wrap behavior

From: Ralf Wildenhues
Subject: Re: m4_wrap behavior
Date: Wed, 14 Jun 2006 13:29:17 +0200
User-agent: Mutt/1.5.11

Hello Stepan,

* Stepan Kasal wrote on Tue, Jun 13, 2006 at 10:46:31PM CEST:
> The obvious consequence is that Autoconf <= 2.60 won't work with GNU
> m4 2.0.
> Luckily, there is no risk of installing a broken version of autoconf;
> the build will break, since is a m4sh script.

This is far from realistic.  The system on which the Autoconf package
(.deb, or .rpm, or whatever) is created is not necessarily the system 
on which it is eventually installed.  So this means extra burden on the
distributors to add a conflict of m4 >= 2.0 with Autoconf <= 2.60,
not to speak of the possibility to just set the environment variable M4
at autoconf run time.

If there is a clean, easy, quick fix to this, we want it in 2.60.
We only have to make sure not to add or remove diversions: third party
packages use them, although they shouldn't.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]