[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Issue with ./config.status --recheck

From: Thomas Petazzoni
Subject: Issue with ./config.status --recheck
Date: Fri, 7 Aug 2009 18:52:26 +0200


I'm having an issue with ./config.status --recheck re-running
the ./configure script, but without all the environment variables that
have been passed to the original ./configure call, making the build
fail later because some tools cannot be found (in my case, the proper

I'm presently having the issue while compiling libtool-1.5.24, but this
is a problem that also occurs with other packages. It's probably
because I'm doing something wrong, but I can't figure out what.

Here is what I do to produce the problem :

 1. Extract libtool-1.5.24.tar.gz

 2. touch libltdl/acinclude.m4 (in reality, I'm modifying this file,
    but the issue I'm having gets produced just if this file is more
    recent that the others)

 3. Configure with the following line:

    CC=/usr/local/xtools/arm-unknown-linux-uclibcgnueabi/bin/arm-linux-gcc \
    ./configure --target=arm-linux --host=arm-linux --build=i386-pc-linux-gnu

    The configure correctly detects

    checking for

    both for the libtool main configure script and libltdl configure

 4. I run make, which runs aclocal, then automake, then autoconf,
    then ./config.status --recheck:

/bin/bash ./config.status --recheck
running CONFIG_SHELL=/bin/bash /bin/bash ./configure --prefix=/usr/local 
--target=arm-linux --host=arm-linux --build=i386-pc-linux-gnu 
build_alias=i386-pc-linux-gnu host_alias=arm-linux target_alias=arm-linux 
--enable-ltdl-install --cache-file=/dev/null --srcdir=.  --no-create 

    Obviously, it passed the CC= variable, but not the STRIP= variable.
    Therefore, the new execution of the configure script detects:

    checking for arm-linux-strip... no

 5. At install time, I do "make DESTDIR=/tmp/foo install-strip", and it
    fails with:

/usr/bin/install -c .libs/ 
strip --strip-unneeded /tmp/meuh/usr/local/lib/
strip: Unable to recognise the format of the input file 
make[3]: *** [install-libLTLIBRARIES] Error 1

    because it tries to strip an ARM library with the x86 strip, which
    cannot work.

I've also attached the full log of what's happening (which commands I'm
running, and their full output).

Do you have any ideas of what I'm doing wrong ?

Thanks a lot!

Thomas Petazzoni, Free Electrons
Kernel, drivers and embedded Linux development,
consulting, training and support.

Attachment: config-status-issue.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]