[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: facing error making autoconf - make[3]: *** [m4sugar.m4f] Error 1

From: Eric Blake
Subject: Re: facing error making autoconf - make[3]: *** [m4sugar.m4f] Error 1
Date: Thu, 07 Apr 2011 08:13:12 -0600
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110307 Fedora/3.1.9-0.39.b3pre.fc14 Lightning/1.0b3pre Mnenhy/0.8.3 Thunderbird/3.1.9

On 04/07/2011 01:38 AM, rden wrote:
> Hello,
> I am currently trying to install autoconf and I'm facing the same problem,
> though the solution you proposed seems not to work for me. 
> I'm running MinGW 5.6.1, m4 1.4.15 atm and tried with autoconf 2.60, 2.61,
> 2.62 and 2.67 atm. I also added some M4 environment variable, no changes. 
> However, I am not sure to have properly installed m4, as I'm completely new
> at this. I've put the extracted files in my "C:/msys/1.0/bin" and done the
> classical "configure/make/make install".
> Here is my error:
> mv version.m4-t version.m4
> autom4te_perllibdir='../..'/lib AUTOM4TE_CFG='../../lib/autom4te.cfg'        
> ../../bin/autom4te -B '../..'/lib -B '../..'/lib                              
> \
>         --language=m4sugar                      \
>         --freeze                        \
>         --output=m4sugar.m4f
> autom4te: freezing produced output:
> autom4te: 

This is almost surely caused by running on a platform that is not
consistently handling carriage returns (some, but not all, of the
programs in your tool chain are handling files in text mode instead of
binary mode).

You may have better luck asking on mingw lists to see how other people
have solved this, or try a different port for windows (such as cygwin,
which I know from personal experience does not suffer from these problems).

Eric Blake   address@hidden    +1-801-349-2682
Libvirt virtualization library

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]