[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: help building autoconf

From: Eric Blake
Subject: Re: help building autoconf
Date: Wed, 21 Aug 2013 06:24:47 -0600
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130805 Thunderbird/17.0.8

[adding the list, so others can learn from this...]

On 08/20/2013 12:24 PM, address@hidden wrote:
> You were right. I was defining the environment variable as the path to M4.
> After I changed it to point to the executable itself, everything worked.
> Thanks very much.

Is there any particular piece of documentation we should improve to make
it more obvious that $M4 must point to the binary, rather than the
directory containing the binary?

>>> autom4te: need GNU m4 1.4 or later:
>>> /global/homes/d/dmitryp/m4-1.4.16/install/bin

Hmm, this message is quoting the name of the "binary" it tried to
execute (and executing a directory doesn't do much), but it might be
more helpful if it added a blurb about EISDIR; I wonder if it's worth
trying a patch along those lines.

Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]