[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Issues using autoconf or automake

From: Gavin Smith
Subject: Re: Issues using autoconf or automake
Date: Wed, 12 Mar 2014 19:04:27 +0000

On Wed, Mar 12, 2014 at 2:34 PM, Jim Galarowicz <address@hidden> wrote:
> Hi Gavin, all,
> I ran the
> autoconf --trace AM_CONDITIONAL command in the bootstrap instead of just
> autoconf and here are the results.

It could be a problem with aclocal. You said that your bootstrap script worked:

aclocal --force -I m4
   libtoolize --force --ltdl --copy
   autoheader -f
   automake --foreign --add-missing --copy

But make clean didn't:

make clean
CDPATH="${ZSH_VERSION+.}:" && cd . && aclocal-1.13 -I libltdl/m4
 cd . && automake-1.13 --foreign error: HAVE_QTLIB does not appear in AM_CONDITIONAL

The first time aclocal is called it has "-I m4" as an argument, the
second it doesn't. I don't think it should be needed because I see you
have "AC_CONFIG_MACRO_DIR([m4])" in, but it is something
to try. You also have a line "ACLOCAL_AMFLAGS = -I libltdl/m4" in Maybe you could try changing this to "ACLOCAL_AMFLAGS =
-I libltdl/m4 -I m4" to see if it makes a difference.

This is more likely a libtool or automake problem and not an autoconf
problem; I suggest asking on one of their mailing lists for help.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]