[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [GNU Autoconf 2.69] OSX autotools: `aclocal.m4' not being output by

From: Eric Blake
Subject: Re: [GNU Autoconf 2.69] OSX autotools: `aclocal.m4' not being output by `autom4te'
Date: Thu, 26 Jun 2014 09:38:37 -0600
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0

On 06/26/2014 08:54 AM, Jeff Sheen wrote:
> Eric,
> I know what is causing the issue.
> I tried a fresh Mavericks install with just XCode 5.1.1 and Macports 
> installed, and encountered the exact same problem.
> I then realised that the only remaining difference between my environment and 
> a vanilla environment, is that my development directories are on a FAT32 disk.

Thanks for the analysis.  FAT is a notoriously bad file system, for how
non-POSIX compliant it is.

> Indeed, the Autotools configuration worked as expected with a copy of the 
> source tree stored on an HFS disk.
> Is it expected behaviour that GNU Autotools are incompatible with some file 
> systems natively supported by the OS?

Not entirely expected, although it may just be a bug in the testsuite
(for expecting too much from the environment) rather than a problem with
the just-built autoconf is still usable.  But to avoid test failures,
we'd need patches from someone that is actively in such a setup (I don't
have access to such a system at the moment, so it would be a while to
wait if you are expecting me to try and come up with such patches).

Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]