[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Conditionally including macros that require a newer autoconf version

From: Rainer Gerhards
Subject: Conditionally including macros that require a newer autoconf version
Date: Tue, 26 Jul 2016 09:06:55 +0200

Hi all,

please excuse my limited autoconf knowledge.

I want to add the AX_COMPILE_FLAGS macro to my projects in order to
produce better code. Unfortunately, this macro (more precise: it's
helpers) require at least autoconf 2.64. This is not available on a
number of platforms, Centos 6 is an example (2.61). I don't want to
prevent users from building my projects just because the
AX_COMPILE_FLAGS macro requires newer autoconf -- after all, this is
more or less a development aid.

I initially tried to disable it based on the autoconf version. But I
found out that the macro that obtains this version requires 2.62,
which I also do not have on many platforms. So I tried to add a
conditional switch to disable this macro:

Unfortunately, this does not work either. As it looks, autoreconf
already checks the macro dependencies, so this happens at a stage
before the switch can be used:

I wonder if there is any way to disable that macro, other than
manually removing and re-inserting it on a as-needed basis (which
really is not a good solution).

Any advise is deeply appreciated.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]