[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Trying to run autogen

From: Erik Moe
Subject: Trying to run autogen
Date: Mon, 12 Dec 2016 12:52:03 -0600

I’m new to autogen/autoconf.  I’m trying to build urjag on macOS Sierra: 
svn://  I initially tried to build using the 
latest autoconf, automake, gettext provided by homebrew, but I keep getting an 
error "unknown channel m4trace: -1- AS_VAR_APPEND(ac_configure_args, " 
'$ac_arg’”)”.  I then built my own copies of autoconf, automake and gettext 
using the versions that were specified in the autoconf-2.64, 
automake-1.10 and gettext-0.17.  Either way I get essentially the same error.  
Could someone give me some direction as I don’t have much experience in this 
area.  I’ve attached the file.

./ . 
autoreconf: Entering directory `.'
autoreconf: running: autopoint --force
autoreconf: running: aclocal --force -I m4
main::scan_file() called too early to check prototype at 
/Users/emoe/Projects/BusBlaster/dist/bin/aclocal line 603.
Use of uninitialized value $msg in concatenation (.) or string at 
/Users/emoe/Projects/BusBlaster/dist/bin/autom4te line 1024.
unknown channel m4trace: -1- AS_VAR_APPEND(ac_configure_args, " '$ac_arg'")
 at /Users/emoe/Projects/BusBlaster/dist/share/autoconf/Autom4te/ 
line 634.
        Autom4te::Channels::msg('m4trace: -1- AS_VAR_APPEND(ac_configure_args, 
" \'$ac_arg\'")\x{a}', undef, 'warning: ') called at 
/Users/emoe/Projects/BusBlaster/dist/bin/autom4te line 1024
aclocal: autom4te failed with exit status: 1
autoreconf: aclocal failed with exit status: 1

autoreconf failed.

Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]