[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

absolute beginner

From: Catonano
Subject: absolute beginner
Date: Tue, 6 Jun 2017 12:25:44 +0200


I'd like to create a Guile Scheme project linking to a C library, Freexl.

I copied guile-gcrypt, it does exactly that

Then I changed all thhe occurrences of "gcrypt" to "freexl"

But when I run configure in guile-gcrypt I get

checking for guile-config... /home/me/.guix-profile/bin/guile-config
checking for libgcrypt-config...
checking libgcrypt's library directory...
checking for libgcrypt shared library name...

As you can see it checks that "...bin/libgcrypt-config" is present AND it
checks the "shared library name"

But when I run it in my guile-freexl II get

checking for guile-config... /home/me.guix-profile/bin/guile-config
checking for freexl shared library name...

as you can see it DOESN'T look for any ...bin/freexl-config AND it doesn't
look for the library shared name

why ?

It is substantially the same repo, I cloned it and changed the strings
"gcrypt" to "freexl"

That's all I did

Thanks in advance

reply via email to

[Prev in Thread] Current Thread [Next in Thread]