[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Skip all version checks with autoconf?

From: Jeffrey Walton
Subject: Re: Skip all version checks with autoconf?
Date: Fri, 24 Aug 2018 19:12:46 -0400

On Fri, Aug 24, 2018 at 6:59 PM, Jeffrey Walton <address@hidden> wrote:
>> It is not autoconf's problem when someone writes a that wrongly
>> claims to use too-new of a version of automake.  But if you don't think the
>> package is actually relying on a feature that only that newer automake
>> provided, you are welcome to edit and change the
>> AM_INIT_AUTOMAKE() line to list a lower version number, rerun autoreconf,
>> and see if it completes successfully.
> OK, let's get rid of these useless checks whose only purpose is to
> stop someone from accomplishing their task at hand.
>      sed -i '/AM_INIT_AUTOMAKE/d'
> And what a surprise:
>     $ autoreconf -f -i
>     Can't exec "autopoint": No such file or directory at
> /usr/share/autoconf/Autom4te/ line 345.
>     autoreconf: failed to run autopoint: No such file or directory
> Autotools does everything in its freaking powers to stop someone from
> accomplishing their task.
>> Or, actually install newer versions of the autotools.
> Lol... That put milk up my nose. I've tried to install newer versions
> and they have never worked right. The admins on the GCC compile farm
> tried the same and the shit does not work right. Claiming someone can
> upgrade these tools is a joke.

All version numbers have been changed to 0.00. This is the joke we
have to contend with:

$ autoreconf -f -i
autopoint: *** The AM_GNU_GETTEXT_VERSION declaration in your
               file requires the infrastructure from gettext-0.00 but
this version
               is older. Please upgrade to gettext-0.00 or newer.
autopoint: *** Stop.

How do you get older than the first version of a package???

For the love of Christ, stop it with these useless version numbers.
All they do is stop someone from accomplishing their task. Let the
task fail where it fails if someone is using the feature.

How freaking complicated can a simple 'configure && make && make
install' be made???

reply via email to

[Prev in Thread] Current Thread [Next in Thread]