[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Automake-commit] [SCM] GNU Automake branch, ng/master, updated. v1.12.2

From: Stefano Lattarini
Subject: [Automake-commit] [SCM] GNU Automake branch, ng/master, updated. v1.12.2-534-ga92289e
Date: Fri, 20 Jul 2012 11:39:35 +0000

This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "GNU Automake".;a=commitdiff;h=a92289e43e9303c890a774c2540f5f56bcccfc73

The branch, ng/master has been updated
       via  a92289e43e9303c890a774c2540f5f56bcccfc73 (commit)
       via  1266796e90fcd67cca308e1fb3295a16c3c3e06d (commit)
      from  e11cbc098858b0e37cad641d991b93bf976cd1f8 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit a92289e43e9303c890a774c2540f5f56bcccfc73
Author: Stefano Lattarini <address@hidden>
Date:   Fri Jul 20 13:34:14 2012 +0200

    [ng] fixup: remove deleted test from XFAIL_TESTS
    * (XFAIL_TESTS): Here, the test 't/'.
    Signed-off-by: Stefano Lattarini <address@hidden>

commit 1266796e90fcd67cca308e1fb3295a16c3c3e06d
Author: Stefano Lattarini <address@hidden>
Date:   Wed Jul 18 20:26:41 2012 +0200

    [ng] vars: names for internal make variables: '' and ''
    That is the new preferred naming scheme: '' where we would
    have previously used something like 'am__foo', and ''
    where we would have previously used something like 'am__foo_bar_baz'
    or 'am__foo__bar_baz'.
    We should start using the new naming to do so in future commits.  But
    we should also avid a sweeping rename for now, to minimize conflicts
    with the mainline Automake codebases, which (for portability reason)
    must still limit itself to the use of the 'am__' prefix.
    * HACKING: Adjust.  Also, remove now-irrelevant advice about the
    problem of an old vendor make (NEWS-OS 4.2R) with variables whose
    name start with an underscore.
    Signed-off-by: Stefano Lattarini <address@hidden>


Summary of changes:
 HACKING     |   21 +++++++++++---------- |    1 -
 2 files changed, 11 insertions(+), 11 deletions(-)

diff --git a/HACKING b/HACKING
index c15718f..03b9dd5 100644
@@ -41,16 +41,17 @@
 = Naming
-* We've adopted the convention that internal AC_SUBSTs should be
-  named with a leading 'am__', and internally generated targets
-  should be named with a leading 'am--'.  This convention, although
-  in place from at least February 2001, isn't yet universally used.
-  But all new code should use it.
-  We used to use '_am_' as the prefix for an internal AC_SUBST.
-  However, it turns out that NEWS-OS 4.2R complains if a Makefile
-  variable begins with the underscore character.  Yay for them.
-  I changed the target naming convention just to be safe.
+* Internal make variables and functions should be named following patterns
+  like 'am.tty-colors' or 'am.dist.files'.
+* Internal AC_SUBSTs should be named with a leading 'am__'.
+* Private make targets should be named with a leading 'am--'.
+* WARNING! This convention, introduced recently (since July 2012),
+  isn't yet universally used.  But all new code should use it,
+  except in those situation where that would cause spurious
+  conflicts with mainline Automake.
 = Editing '.am' files
diff --git a/ b/
index 290d5f4..27120ef 100644
--- a/
+++ b/
@@ -354,7 +354,6 @@ XFAIL_TESTS = \
   t/ \
   t/ \
   t/ \
-  t/ \
   t/ \

GNU Automake

reply via email to

[Prev in Thread] Current Thread [Next in Thread]