[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

new depcomp causes trouble w/fileutils

From: Jim Meyering
Subject: new depcomp causes trouble w/fileutils
Date: 11 Jan 2001 17:38:48 +0100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.0.95

Hi Tom,

I use the gcc snapshot of the day (checked out 2001-01-11.04h59 UTC)
and tried putting your latest depcomp into fileutils.  It worked fine
for builds in a directory that was already configured (stale depmode?),
but when I ran `make distcheck', it ended up running in gcc3 mode and
failed because it put preprocessor output in the .o file.

The symptom was that linking failed because the .o file wasn't valid.

Here's s tiny test case that tries to demonstrate what happened:

  $ cat k.c
  int foo () {}
  $ DEPENDENCIES_OUTPUT=1 gcc -c -o k.o k.c -M -MT k.o -MF k.Po
  $ cat k.o
  # 1 "k.c"
  int foo () {}

I'm using automake-1.4b.

| 2001-01-10  Tom Tromey  <address@hidden>
|         * depcomp: Handle gcc 3.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]