[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Variable Expansion

From: Fausto Sanchez
Subject: Variable Expansion
Date: Tue, 04 Sep 2001 15:52:20 -0700

Hi everyone,

Any idea why the $(top_srcdir) does not get expanded to the final Makefiles when running on linux. Everything works when I run on a Solaris system, but when I use the same directory on a Linux system on the final Makefile I don't see the $(top_srcdir). In addition, I get errors when configure runs on linux. I am using the same version of
libtool, automake, and autoconf on Solaris and linux. Here are the errors:

creating libtool
checking for ranlib... (cached) ranlib
/auto/repygb/fas/vegas/QT/VegasSW/configure: top_srcdir: command not found
/auto/repygb/fas/vegas/QT/VegasSW/configure: top_srcdir: command not found
checking for ANSI C header files... no
/auto/repygb/fas/vegas/QT/VegasSW/configure: top_srcdir: command not found
configure: creating ./config.status

The reason it gives me three errors is because I reference top_srcdir three times in the file as $(top_srcdir). So in my file I have the following:

INCLUDES=" -I$(top_srcdir)/isan/include -I$(top_srcdir)/isan/platform/common/include "

When I run configure on a Solaris 2.8 system, the INCLUDE line in the Makefile looks like

INCLUDES = -I$(top_srcdir)/isan/include -I$(top_srcdir)/isan/platform/common/include

On Linux RedHat 7.1 I get the following, without even a trace of $(top_srcdir)

INCLUDES =  -I/isan/include -I/isan/platform/common/include

I tried using {} instead of (), no braces at all, but no success. Any ideas? thanks in advance and thank you all very much for the previous responses I've gotten to my
other questions.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]