[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

AM_PATH_PYTHON(version) does not work properly?

From: Patrick Guio
Subject: AM_PATH_PYTHON(version) does not work properly?
Date: Mon, 19 Nov 2001 16:46:36 +0100 (MET)

Dear all,
I have updated my autoconf/automake/libtool package to
aclocal (GNU automake) 1.5a
autoconf (GNU Autoconf) 2.52g
automake (GNU automake) 1.5a
libtoolize (GNU libtool) 1.4c

and have included a



I am running RH7.2 and have several python commands available. The default
one is python and is version 1.5, there are in addition python2 and python2.1
all of them coming from rpm's.
The problem is that when I run configure, it does not check all the
possibilities as it should do (I have looked at the file python.m4) and
just stop after having tried /usr/bin/python (which is 1.5) without
testing  other possibilties.

checking for python... /usr/bin/python
checking if Python version >= 2... configure: error: too old

I notice in addition that in python.m4

AC_PATH_PROG(PYTHON, python python2.1 python2.0 python1.6 python1.5)

May be there should also be python2?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]